summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-12-17 18:52:24 +0100
committerStefan Agner <stefan.agner@toradex.com>2014-12-18 10:42:58 +0100
commitd8247d9b506318a3bdb3b136b7ee4898e2000b37 (patch)
tree9453a0b12eab3af4c8648ddcfb82f418446631e3 /recipes-kernel
parent392c5a77a1847f17f06fa8e286762a52abcc9bbe (diff)
mcc-kmod: use mcc kernel module from toradex git
In order to make the MCC kernel module working with our newer kernel some changes had been made on the MCC kernel module. The changes are available on the Toradex Github account. Get the MCC kernel module sources from Github.
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kernel-module-mcc/kernel-module-mcc_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-module-mcc/kernel-module-mcc_git.bb b/recipes-kernel/kernel-module-mcc/kernel-module-mcc_git.bb
new file mode 100644
index 0000000..f7a0dec
--- /dev/null
+++ b/recipes-kernel/kernel-module-mcc/kernel-module-mcc_git.bb
@@ -0,0 +1,17 @@
+# Copyright (C) 2013 Timesys Corporation
+SUMMARY = "Multicore communication kernel module"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c8959abcbbe4d6676c58eab9354019e6"
+
+inherit module
+
+SRC_URI = "git://github.com/toradex/mcc-kmod.git;protocol=git;branch=${SRCBRANCH}"
+
+SRCBRANCH = "master"
+SRCREV = "${AUTOREV}"
+
+PV = "1.06"
+
+S = "${WORKDIR}/git"
+
+COMPATIBLE_MACHINE = "(vf60)"