summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-07-17 09:56:46 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-07-17 09:56:46 +0200
commita905fd65a355ca17ea53545a286052e4429d27d2 (patch)
treeb5259fe86878c83408043914d46a563b5108a212 /recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
parent32af8f369b9f496b5cdafa8cf171f3cef374a9bd (diff)
append our V1.1 lxde specialities to the oe-tworaz recipes
Diffstat (limited to 'recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend')
-rw-r--r--recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend b/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
new file mode 100644
index 0000000..d4b5b35
--- /dev/null
+++ b/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
@@ -0,0 +1,30 @@
+PRINC = "1"
+WALLPAPER-MACHINE = "toradex-neutral.png"
+WALLPAPER-MACHINE_colibri-t20 = "toradex-t20.png"
+WALLPAPER-MACHINE_colibri-t30 = "toradex-t30.png"
+
+THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
+FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}-${PV}"], d)}:"
+
+SRC_URI += " \
+ file://autostart.patch \
+ file://consistent_defconfig_dirs.patch \
+ file://toradex-neutral.png \
+ file://${WALLPAPER-MACHINE} \
+ file://wallpaper.patch \
+ file://desktop.conf \
+ file://defaults.list \
+ file://hdmiaudio.sh \
+"
+
+do_install_append () {
+ install -m 0755 -d ${D}/${datadir}/lxde/wallpapers
+ install -m 0644 ${WORKDIR}/toradex-*.png ${D}/${datadir}/lxde/wallpapers/
+ ln -sf ${WALLPAPER-MACHINE} ${D}/${datadir}/lxde/wallpapers/toradex.png
+ rm ${D}/etc/xdg/lxsession/LXDE/desktop.conf
+ install -m 0644 ${WORKDIR}/desktop.conf ${D}/etc/xdg/lxsession/LXDE/
+ install -m 0755 -d ${D}/${datadir}/applications/
+ install -m 0644 ${WORKDIR}/defaults.list ${D}/${datadir}/applications/
+ install -m 0755 -d ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/hdmiaudio.sh ${D}/${bindir}/
+}