summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxdm
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-07-17 09:56:46 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-07-17 09:56:46 +0200
commita905fd65a355ca17ea53545a286052e4429d27d2 (patch)
treeb5259fe86878c83408043914d46a563b5108a212 /recipes-lxde/lxdm
parent32af8f369b9f496b5cdafa8cf171f3cef374a9bd (diff)
append our V1.1 lxde specialities to the oe-tworaz recipes
Diffstat (limited to 'recipes-lxde/lxdm')
-rw-r--r--recipes-lxde/lxdm/lxdm/configfiles.patch26
-rw-r--r--recipes-lxde/lxdm/lxdm/lxdm.sh29
-rw-r--r--recipes-lxde/lxdm/lxdm/missingAM_GLIB_GNU_GETTEXT.patch25
-rw-r--r--recipes-lxde/lxdm/lxdm_0.4.1.bbappend20
4 files changed, 100 insertions, 0 deletions
diff --git a/recipes-lxde/lxdm/lxdm/configfiles.patch b/recipes-lxde/lxdm/lxdm/configfiles.patch
new file mode 100644
index 0000000..37ed74d
--- /dev/null
+++ b/recipes-lxde/lxdm/lxdm/configfiles.patch
@@ -0,0 +1,26 @@
+diff -ur lxdm-0.4.1/data.orig//lxdm.conf lxdm-0.4.1/data/lxdm.conf
+--- lxdm-0.4.1/data.orig//lxdm.conf 2011-07-29 15:44:51.000000000 +0200
++++ lxdm-0.4.1/data/lxdm.conf 2011-12-31 12:22:46.000000000 +0100
+@@ -1,6 +1,6 @@
+ [base]
+ ## uncomment and set autologin username to enable autologin
+-# autologin=dgod
++autologin=root
+
+ ## uncomment and set timeout to enable timeout autologin,
+ ## the value should >=5
+diff -ur lxdm-0.4.1/data.orig//PostLogout.in lxdm-0.4.1/data/PostLogout.in
+--- lxdm-0.4.1/data.orig//PostLogout.in 2011-07-29 15:42:33.000000000 +0200
++++ lxdm-0.4.1/data/PostLogout.in 2011-12-31 12:21:41.000000000 +0100
+@@ -1,3 +1,9 @@
+ #!/bin/sh
+-#
+-# Note: this is a sample and will not be run as is.
++
++#https://wiki.archlinux.org/index.php/LXDE#LXDM
++
++# Kills all your processes when you log out.
++killall --user $USER -TERM
++
++# Set's the desktop background to solid black. Useful if you have multiple monitors.
++xsetroot -solid black
diff --git a/recipes-lxde/lxdm/lxdm/lxdm.sh b/recipes-lxde/lxdm/lxdm/lxdm.sh
new file mode 100644
index 0000000..e6e8e23
--- /dev/null
+++ b/recipes-lxde/lxdm/lxdm/lxdm.sh
@@ -0,0 +1,29 @@
+#! /bin/sh
+### BEGIN INIT INFO
+# Provides: lxdm
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: LXDM Display Manager (and wrapper script)
+# Description: init script for the LXDM Display Manager
+# Copied from SLIM openembedded recipe
+### END INIT INFO
+
+case $1 in
+ start)
+ /usr/sbin/lxdm -d &> /dev/null
+ ;;
+ stop)
+ killall /usr/sbin/lxdm
+ ;;
+ restart)
+ $0 stop
+ sleep 2
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 [start|stop|restart]"
+ ;;
+esac
+
+# End of file
+
diff --git a/recipes-lxde/lxdm/lxdm/missingAM_GLIB_GNU_GETTEXT.patch b/recipes-lxde/lxdm/lxdm/missingAM_GLIB_GNU_GETTEXT.patch
new file mode 100644
index 0000000..43a8b1c
--- /dev/null
+++ b/recipes-lxde/lxdm/lxdm/missingAM_GLIB_GNU_GETTEXT.patch
@@ -0,0 +1,25 @@
+diff -urNdb lxdm-0.4.1.old//config.h.in lxdm-0.4.1//config.h.in
+--- lxdm-0.4.1.old//config.h.in 2011-07-29 15:43:45.000000000 +0200
++++ lxdm-0.4.1//config.h.in 2011-11-29 22:26:14.000000000 +0100
+@@ -1,5 +1,8 @@
+ /* config.h.in. Generated from configure.ac by autoheader. */
+
++/* always defined to indicate that i18n is enabled */
++/*#undef ENABLE_NLS*/
++
+ /* Gettext package. */
+ #undef GETTEXT_PACKAGE
+
+diff -urNdb lxdm-0.4.1.old//configure.ac lxdm-0.4.1//configure.ac
+--- lxdm-0.4.1.old//configure.ac 2011-07-29 15:42:33.000000000 +0200
++++ lxdm-0.4.1//configure.ac 2011-11-29 22:23:08.000000000 +0100
+@@ -141,6 +141,9 @@
+ GETTEXT_PACKAGE=lxdm
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Gettext package.])
++AM_GLIB_GNU_GETTEXT
++
++#AC_SUBST(GMSGFMT, ($MSGFMT))
+
+ AC_CONFIG_FILES([
+ Makefile
diff --git a/recipes-lxde/lxdm/lxdm_0.4.1.bbappend b/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
new file mode 100644
index 0000000..ce46a81
--- /dev/null
+++ b/recipes-lxde/lxdm/lxdm_0.4.1.bbappend
@@ -0,0 +1,20 @@
+PRINC = "1"
+
+THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
+FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
+
+SRC_URI += " \
+ file://missingAM_GLIB_GNU_GETTEXT.patch \
+ file://configfiles.patch \
+"
+pkg_postinst_${PN}() {
+ # Register up as default dm
+ mkdir -p ${sysconfdir}/X11/
+ echo "${sbindir}/lxdm" > ${sysconfdir}/X11/default-display-manager
+ # the lxdm script in init.d includes the script functions, make an empty one if this does not yet exist
+ touch /etc/init.d/functions
+}
+
+pkg_postrm_${PN} () {
+ sed -i /lxdm/d ${sysconfdir}/X11/default-display-manager || true
+}