summaryrefslogtreecommitdiff
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-03-29 10:12:09 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2016-03-30 18:07:26 +0200
commit953f6a2d93c9d4590d5fe9d572279e7ce0369c34 (patch)
treed8b7f97649f6ca7394ee3460508e98e9cdeea069 /recipes-multimedia
parent31b0e7430b4f4a2ce0bd47e6a61684c1fde6ac58 (diff)
gstreamer: fix argument parsing when using Bison 3
Use Stefan's patch until it is available from the meta-openembedded jethro branch. http://cgit.openembedded.org/meta-openembedded/commit/?h=master-next&id=bf8f27af3954ab68e39712516ab515de90b4db27 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer/0001-parse-make-grammar.y-work-with-Bison-3.patch35
-rw-r--r--recipes-multimedia/gstreamer/gstreamer_0.10.%.bbappend9
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer/0001-parse-make-grammar.y-work-with-Bison-3.patch b/recipes-multimedia/gstreamer/gstreamer/0001-parse-make-grammar.y-work-with-Bison-3.patch
new file mode 100644
index 0000000..dc2d606
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer/0001-parse-make-grammar.y-work-with-Bison-3.patch
@@ -0,0 +1,35 @@
+From 60516f4798894f958fc53b470e1283318d0f8706 Mon Sep 17 00:00:00 2001
+From: Kerrick Staley <kerrick@kerrickstaley.com>
+Date: Tue, 20 Aug 2013 23:59:29 -0700
+Subject: [PATCH 1/2] parse: make grammar.y work with Bison 3
+
+YYLEX_PARAM is no longer supported in Bison 3.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=706462
+---
+ gst/parse/grammar.y | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y
+index 24fc87b..7f9dd16 100644
+--- a/gst/parse/grammar.y
++++ b/gst/parse/grammar.y
+@@ -26,7 +26,6 @@
+ */
+
+ #define YYERROR_VERBOSE 1
+-#define YYLEX_PARAM scanner
+
+ #define YYENABLE_NLS 0
+
+@@ -648,6 +647,7 @@ static int yyerror (void *scanner, graph_t *graph, const char *s);
+ %right '.'
+ %left '!' '='
+
++%lex-param { void *scanner }
+ %parse-param { void *scanner }
+ %parse-param { graph_t *graph }
+ %pure-parser
+--
+2.7.2
+
diff --git a/recipes-multimedia/gstreamer/gstreamer_0.10.%.bbappend b/recipes-multimedia/gstreamer/gstreamer_0.10.%.bbappend
new file mode 100644
index 0000000..9886c7d
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer_0.10.%.bbappend
@@ -0,0 +1,9 @@
+# use this patch: http://cgit.openembedded.org/meta-openembedded/commit/?h=master-next&id=bf8f27af3954ab68e39712516ab515de90b4db27
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer:"
+SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
+ file://check_fix.patch \
+ file://gst-inspect-check-error.patch \
+ file://0001-baseparse-Fix-self-comparison-always-evaluates-to-tr.patch \
+ file://0001-parse-make-grammar.y-work-with-Bison-3.patch \
+"