summaryrefslogtreecommitdiff
path: root/recipes-qt/qt4/qt4-x11-free-systemd.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-03-27 16:58:42 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-03-27 16:58:42 +0100
commitbc5f5a67a5850d2a68527d37de6b512854a72f93 (patch)
treeb4017f97c090a33fddc7e74458759dae60ce5ea7 /recipes-qt/qt4/qt4-x11-free-systemd.bb
parent45be656793b6def38c70b2db61eada176b4d6e90 (diff)
images: added a QT4 X11 image
- bbappends to the base qt4-x11-free recipe to use OpenGL ES2 - script which starts X plus qtdemo, including a systemd service to activate script
Diffstat (limited to 'recipes-qt/qt4/qt4-x11-free-systemd.bb')
-rw-r--r--recipes-qt/qt4/qt4-x11-free-systemd.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-qt/qt4/qt4-x11-free-systemd.bb b/recipes-qt/qt4/qt4-x11-free-systemd.bb
new file mode 100644
index 0000000..2c8227c
--- /dev/null
+++ b/recipes-qt/qt4/qt4-x11-free-systemd.bb
@@ -0,0 +1,24 @@
+SECTION = "x11/libs"
+DESCRIPTION = "qtdemo autostart"
+RDEPENDS_${PN} = ""
+# The license is meant for this recipe and the files it installs.
+# RNDIS is part of the kernel, udhcpd is part of busybox
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r1"
+
+inherit allarch systemd
+
+SRC_URI = "file://qtdemo.service \
+ file://qtdemo-init "
+
+FILES_${PN} += " ${sysconfdir}/init.d "
+do_install () {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/qtdemo-init ${D}/${sysconfdir}/init.d/
+}
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "qtdemo.service"