summaryrefslogtreecommitdiff
path: root/recipes-qt/qt5/qt3d_%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-01-15 10:47:19 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 13:46:01 +0100
commitb8af4cae40e60a53b599f3eb754db53a8650f52c (patch)
tree4b19571bfe3f63fcfab343c8c44b548cc682a89f /recipes-qt/qt5/qt3d_%.bbappend
parente9e1fb8ad92310a67f442b646946a0d91820c520 (diff)
qt3d: address race condition
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-qt/qt5/qt3d_%.bbappend')
-rw-r--r--recipes-qt/qt5/qt3d_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt3d_%.bbappend b/recipes-qt/qt5/qt3d_%.bbappend
index a233414..85d7eab 100644
--- a/recipes-qt/qt5/qt3d_%.bbappend
+++ b/recipes-qt/qt5/qt3d_%.bbappend
@@ -1,3 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/qt3d:"
+
# qt3d links against the opengl flavours we configured qtbase for, so
# depend on them here
DEPENDS_GLES = ""
@@ -7,3 +9,5 @@ DEPENDS_GLES_use-mainline-bsp += "virtual/libgles2 virtual/egl"
DEPENDS_class-target += " ${DEPENDS_GLES}"
+# Fix race condition
+SRC_URI += "file://0001-qt3d-do-not-set-resources_big.patch"