summaryrefslogtreecommitdiff
path: root/recipes-qt
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-01-07 18:52:19 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 13:44:33 +0100
commit15f04e6f015747df2aaf594c875e0764a6cdf171 (patch)
tree08998180fcdb41f23f9ea6c98e7a1bc06facee17 /recipes-qt
parent43088430f9d261426eb1d9835525549cf371ebfc (diff)
apalis/colibri-t20 -t30: drop machines
These machines use an old Nvidia provided downstream kernel 3.1.10. They are no longer compatible with more recent sysroot components, e.g. libc, xserver et. al. The maintenance burden to keep the userspace components in their old version becomes simply to high. Keep using the rocko based 2.8 BSP for these machines. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt4/qt4-x11-free_%.bbappend5
-rw-r--r--recipes-qt/qt5/qt3d_%.bbappend1
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend3
-rw-r--r--recipes-qt/qt5/qtmultimedia_%.bbappend7
-rw-r--r--recipes-qt/qt5/qtwebkit_%.bbappend4
5 files changed, 0 insertions, 20 deletions
diff --git a/recipes-qt/qt4/qt4-x11-free_%.bbappend b/recipes-qt/qt4/qt4-x11-free_%.bbappend
deleted file mode 100644
index 0f0fb17..0000000
--- a/recipes-qt/qt4/qt4-x11-free_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-# Build OpenGL/ES support if available
-
-QT_GLFLAGS_tegra = "-opengl es2 "
-
-DEPENDS_append_tegra += "virtual/libgles2"
diff --git a/recipes-qt/qt5/qt3d_%.bbappend b/recipes-qt/qt5/qt3d_%.bbappend
index 4807e4a..a233414 100644
--- a/recipes-qt/qt5/qt3d_%.bbappend
+++ b/recipes-qt/qt5/qt3d_%.bbappend
@@ -1,7 +1,6 @@
# qt3d links against the opengl flavours we configured qtbase for, so
# depend on them here
DEPENDS_GLES = ""
-DEPENDS_GLES_tegra = "virtual/libgles2 virtual/egl"
DEPENDS_GLES_imxpxp += "virtual/libgles2 virtual/egl"
DEPENDS_GLES_imgpu3d += "virtual/libgles2 virtual/egl"
DEPENDS_GLES_use-mainline-bsp += "virtual/libgles2 virtual/egl"
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index 57ae7ef..0b6f29b 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,4 +1,3 @@
-PACKAGECONFIG_GL_tegra = "gles2"
PACKAGECONFIG_EXAMPLES ?= "examples"
# | /build/krm/oe-core_V2.6/build/out-glibc/work/armv7at2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.1+gitAUTOINC+5afc431323-r0/git/src/widgets/styles/qgtkstyle.cpp: In member function 'virtual QRect QGtkStyle::subControlRect(QStyle::ComplexControl, const QStyleOptionComplex*, QStyle::SubControl, const QWidget*) const':
@@ -18,5 +17,3 @@ PACKAGECONFIG_append = " \
icu \
${PACKAGECONFIG_EXAMPLES} \
"
-
-PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"
diff --git a/recipes-qt/qt5/qtmultimedia_%.bbappend b/recipes-qt/qt5/qtmultimedia_%.bbappend
deleted file mode 100644
index d398475..0000000
--- a/recipes-qt/qt5/qtmultimedia_%.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-PACKAGECONFIG_append_tegra = " \
- gstreamer010 \
-"
-PACKAGECONFIG_remove_tegra = " \
- gstreamer \
-"
-PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"
diff --git a/recipes-qt/qt5/qtwebkit_%.bbappend b/recipes-qt/qt5/qtwebkit_%.bbappend
deleted file mode 100644
index 920d80b..0000000
--- a/recipes-qt/qt5/qtwebkit_%.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-PACKAGECONFIG_remove_tegra = " \
- gstreamer \
-"
-PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"