summaryrefslogtreecommitdiff
path: root/recipes-qt
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-10-01 14:35:18 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-22 15:46:52 +0100
commit10f3554e3aa7e5d8e74d926f204d4907bacc00c0 (patch)
treef7f5098a8f979875ed663b004c4c54c59060195b /recipes-qt
parent7ff195da59a1cb71c1b5949a5ba686b06ce35606 (diff)
recipes: fix invalid license file location
Use '${COMMON_LICENSE_DIR} for license files fix the warning: | WARNING: packagegroup-xfce-base-1.0-r5 do_populate_lic: | ${COREBASE}/LICENSE is not a valid license file, please use |'${COMMON_LICENSE_DIR}/MIT' for a MIT License file in LIC_FILES_CHKSUM. |This will become an error in the future Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt-demo/qt-demo-init_0.2.bb3
-rw-r--r--recipes-qt/qt4/qt4-x11-free-systemd.bb2
-rw-r--r--recipes-qt/qt5/qt5-x11-free-systemd.bb2
3 files changed, 3 insertions, 4 deletions
diff --git a/recipes-qt/qt-demo/qt-demo-init_0.2.bb b/recipes-qt/qt-demo/qt-demo-init_0.2.bb
index 7ad4c65..fa2ed23 100644
--- a/recipes-qt/qt-demo/qt-demo-init_0.2.bb
+++ b/recipes-qt/qt-demo/qt-demo-init_0.2.bb
@@ -2,8 +2,7 @@ SUMMARY = "Systemd start script for Qt Embedded demo"
LICENSE = "MIT"
PR = "r1"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
inherit allarch systemd
diff --git a/recipes-qt/qt4/qt4-x11-free-systemd.bb b/recipes-qt/qt4/qt4-x11-free-systemd.bb
index 568d354..b08f159 100644
--- a/recipes-qt/qt4/qt4-x11-free-systemd.bb
+++ b/recipes-qt/qt4/qt4-x11-free-systemd.bb
@@ -3,7 +3,7 @@ SUMMARY = "systemd qtdemo autostart"
# The license is meant for this recipe and the files it installs.
# RNDIS is part of the kernel, udhcpd is part of busybox
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
PR = "r1"
diff --git a/recipes-qt/qt5/qt5-x11-free-systemd.bb b/recipes-qt/qt5/qt5-x11-free-systemd.bb
index 95483e8..f6ba46d 100644
--- a/recipes-qt/qt5/qt5-x11-free-systemd.bb
+++ b/recipes-qt/qt5/qt5-x11-free-systemd.bb
@@ -3,7 +3,7 @@ SUMMARY = "systemd qtapplication autostart"
# The license is meant for this recipe and the files it installs.
# RNDIS is part of the kernel, udhcpd is part of busybox
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
inherit allarch systemd