summaryrefslogtreecommitdiff
path: root/recipes-qt
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-12-26 13:57:02 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-09-29 06:31:16 +0200
commit99197f671cfffca7c201115a70265575b34b94d4 (patch)
tree5c2dd7c62cf266e523f9e2d19de5b5cb3eb37020 /recipes-qt
parenta9b3111a10c87eb6c93b5bcbf2fefbecb1a53aa2 (diff)
recipes: stop using base_contains
The base_contains function is deprecated and we ought to use bb.utils.contains instead. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index 40d8286..bce4665 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -8,7 +8,7 @@ PACKAGECONFIG_EXAMPLES ?= "examples"
# | /build/krm/oe-core_V2.6/build/out-glibc/work/armv7at2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.1+gitAUTOINC+5afc431323-r0/git/src/widgets/styles/qgtkstyle.cpp:3636:74: error: 'QAccessible' has not been declared
# | } else if (QStyleHelper::isInstanceOf(groupBox->styleObject, QAccessible::Grouping)) {
-QT_CONFIG_FLAGS_append = "${@base_contains('DISTRO_FEATURES', 'x11', ' -accessibility ', '', d)}"
+QT_CONFIG_FLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -accessibility ', '', d)}"
#qtbase must be configured with icu for qtwebkit
PACKAGECONFIG_append_tegra = " \