summaryrefslogtreecommitdiff
path: root/recipes-sato/webkit/webkitgtk_%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-07-02 11:17:00 +0200
committerStefan Agner <stefan.agner@toradex.com>2017-01-10 14:59:20 -0800
commita6623d0739ef086930335292fc25f0f785de21fa (patch)
treeb9bcb579e479671927899c06992143f3a70e33c5 /recipes-sato/webkit/webkitgtk_%.bbappend
parent40617d48b40425752a9829d0bae93197db9f6870 (diff)
webkitgtk bbappend: use version wildcard
While at it override packageconfig only if built for vybrid. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-sato/webkit/webkitgtk_%.bbappend')
-rw-r--r--recipes-sato/webkit/webkitgtk_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-sato/webkit/webkitgtk_%.bbappend b/recipes-sato/webkit/webkitgtk_%.bbappend
new file mode 100644
index 0000000..8114309
--- /dev/null
+++ b/recipes-sato/webkit/webkitgtk_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI += "file://minibrowser.desktop"
+
+do_install_append() {
+ install -m 0644 -D ${WORKDIR}/minibrowser.desktop ${D}${datadir}/applications/minibrowser.desktop
+}
+
+PACKAGECONFIG_vf = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)}"
+
+ARM_INSTRUCTION_SET_vf = "thumb"
+
+PACKAGE_ARCH_vf = "${MACHINE_ARCH}"