summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-07-21 19:13:07 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-07-21 19:13:07 +0200
commitdc2aa9fb090e8b75c1473209463615e15b3e242d (patch)
tree9723d22a7de98763966b2dfd94d0d92b322312b9 /recipes
parent010b27fbdefacd2be7ad689540636dae5985d1f0 (diff)
set DISPLAY=:0.0
Diffstat (limited to 'recipes')
-rw-r--r--recipes/base-files/base-files/colibri-t20/profile35
-rw-r--r--recipes/base-files/base-files/colibri-t30/profile35
-rw-r--r--recipes/base-files/base-files_3.0.14.bbappend3
3 files changed, 71 insertions, 2 deletions
diff --git a/recipes/base-files/base-files/colibri-t20/profile b/recipes/base-files/base-files/colibri-t20/profile
new file mode 100644
index 0000000..c1ee240
--- /dev/null
+++ b/recipes/base-files/base-files/colibri-t20/profile
@@ -0,0 +1,35 @@
+# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
+# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
+
+PATH="/usr/local/bin:/usr/bin:/bin"
+EDITOR="/bin/vi" # needed for packages like cron
+test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
+
+if [ ! -e /etc/localtime ]; then
+ TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
+ # for an explanation of how to set this to your local timezone.
+ export TZ
+fi
+
+if [ "$HOME" = "/home/root" ]; then
+ PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin
+fi
+if [ "$PS1" ]; then
+# works for bash and ash (no other shells known to be in use here)
+ PS1='\u@\h:\w\$ '
+fi
+
+if [ -d /etc/profile.d ]; then
+ for i in /etc/profile.d/* ; do
+ . $i
+ done
+ unset i
+fi
+
+test -z "$DISPLAY" && DISPLAY=":0.0" # have the X display defined, unless it is already set, e.g. by a ssh connection
+export DISPLAY
+
+export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM
+
+umask 022
+
diff --git a/recipes/base-files/base-files/colibri-t30/profile b/recipes/base-files/base-files/colibri-t30/profile
new file mode 100644
index 0000000..c1ee240
--- /dev/null
+++ b/recipes/base-files/base-files/colibri-t30/profile
@@ -0,0 +1,35 @@
+# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
+# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
+
+PATH="/usr/local/bin:/usr/bin:/bin"
+EDITOR="/bin/vi" # needed for packages like cron
+test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
+
+if [ ! -e /etc/localtime ]; then
+ TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
+ # for an explanation of how to set this to your local timezone.
+ export TZ
+fi
+
+if [ "$HOME" = "/home/root" ]; then
+ PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin
+fi
+if [ "$PS1" ]; then
+# works for bash and ash (no other shells known to be in use here)
+ PS1='\u@\h:\w\$ '
+fi
+
+if [ -d /etc/profile.d ]; then
+ for i in /etc/profile.d/* ; do
+ . $i
+ done
+ unset i
+fi
+
+test -z "$DISPLAY" && DISPLAY=":0.0" # have the X display defined, unless it is already set, e.g. by a ssh connection
+export DISPLAY
+
+export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM
+
+umask 022
+
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend
index 1615df3..ca35824 100644
--- a/recipes/base-files/base-files_3.0.14.bbappend
+++ b/recipes/base-files/base-files_3.0.14.bbappend
@@ -1,5 +1,4 @@
-PRINC = "2"
+PRINC = "3"
THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
-