summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-core/systemd/timestamp-service.bbappend1
-rwxr-xr-xrecipes-core/systemd/timestamp-service/load-timestamp.sh18
2 files changed, 0 insertions, 19 deletions
diff --git a/recipes-core/systemd/timestamp-service.bbappend b/recipes-core/systemd/timestamp-service.bbappend
deleted file mode 100644
index 72d991c..0000000
--- a/recipes-core/systemd/timestamp-service.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/recipes-core/systemd/timestamp-service/load-timestamp.sh b/recipes-core/systemd/timestamp-service/load-timestamp.sh
deleted file mode 100755
index b34c7ca..0000000
--- a/recipes-core/systemd/timestamp-service/load-timestamp.sh
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-# Set the system clock from hardware clock
-# If the timestamp is 1 day or more recent than the current time,
-# use the timestamp instead.
-SYSTEMDATE=$(/bin/date -u "+%4Y%2m%2d%2H%2M")
-
-TIMESTAMP=$(/bin/cat /etc/timestamp 2>/dev/null)
-
-if [ ${TIMESTAMP} -gt $SYSTEMDATE ] 2>/dev/null ; then
- echo "Update systemtime from /etc/timestamp"
- /bin/date -u ${TIMESTAMP#????}${TIMESTAMP%????????}
-fi
-
-if [ "$1" = "--save" ] ; then
- /bin/date -u +%4Y%2m%2d%2H%2M > /etc/timestamp
-fi
-