summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-images/images/packagegroup-tdx-qt5.bb79
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb1
2 files changed, 80 insertions, 0 deletions
diff --git a/recipes-images/images/packagegroup-tdx-qt5.bb b/recipes-images/images/packagegroup-tdx-qt5.bb
new file mode 100644
index 0000000..0b3dd7f
--- /dev/null
+++ b/recipes-images/images/packagegroup-tdx-qt5.bb
@@ -0,0 +1,79 @@
+SUMMARY = "Packagegroup which provides most QT5 libraries and a QT5 demo"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES += " \
+ ${PN}-demos \
+ ${PN}-fonts \
+ ${PN}-libs \
+"
+
+RRECOMMENDS_${PN} = " \
+ ${PN}-demos \
+ ${PN}-fonts \
+ ${PN}-libs \
+"
+# Only install qtsmarthome with its dependencies on modules with limited storage
+RRECOMMENDS_${PN}_colibri-imx6ull = "qtsmarthome"
+RRECOMMENDS_${PN}_colibri-imx7 = "qtsmarthome"
+
+SUMMARY_${PN}-demos = "QT5 Demos"
+RRECOMMENDS_${PN}-demos = " \
+ cinematicexperience \
+ qtsmarthome \
+"
+
+SUMMARY_${PN}-fonts = "Some fonts useful for QT5"
+RRECOMMENDS_${PN}-fonts = " \
+ ttf-dejavu-common \
+ ttf-dejavu-sans \
+ ttf-dejavu-sans-mono \
+ ttf-dejavu-serif \
+"
+
+SUMMARY_${PN}-libs = "QT5 libraries"
+RRECOMMENDS_${PN}-libs = " \
+ qt3d \
+ qt5ledscreen \
+ qtbase \
+ qtcharts \
+ qtcoap \
+ qtconnectivity \
+ qtdatavis3d \
+ qtdeclarative \
+ qtgamepad \
+ qtgraphicaleffects \
+ qtimageformats \
+ qtknx \
+ qtlocation \
+ qtlottie \
+ qtmqtt \
+ qtmultimedia \
+ qtnetworkauth \
+ qtopcua \
+ qtpurchasing \
+ qtquick3d \
+ qtquickcontrols \
+ qtquickcontrols2 \
+ qtquicktimeline \
+ qtremoteobjects \
+ qtscript \
+ qtscxml \
+ qtsensors \
+ qtserialbus \
+ qtserialport \
+ qtsvg \
+ qtsystems \
+ qttools \
+ qttranslations \
+ qtvirtualkeyboard \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
+ qtwebchannel \
+ qtwebglplugin \
+ qtwebsockets \
+ qtxmlpatterns \
+"
+
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index 7dd6db4..02b2b44 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -23,6 +23,7 @@ IMAGE_INSTALL += " \
\
packagegroup-tdx-cli \
packagegroup-tdx-graphical \
+ packagegroup-tdx-qt5 \
\
bash \
coreutils \