summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes/images/angstrom-lxde-image.bb34
-rw-r--r--recipes/images/lx.inc14
-rw-r--r--recipes/images/trdx-extra.inc22
3 files changed, 33 insertions, 37 deletions
diff --git a/recipes/images/angstrom-lxde-image.bb b/recipes/images/angstrom-lxde-image.bb
index 4ca8136..3d52d16 100644
--- a/recipes/images/angstrom-lxde-image.bb
+++ b/recipes/images/angstrom-lxde-image.bb
@@ -4,36 +4,34 @@ DESCRIPTION = "Image based on the LXDE desktop"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+PR = "r1"
+
#create the file /etc/timestamp
IMAGE_PREPROCESS_COMMAND = "rootfs_update_timestamp"
-#IMAGE_LINGUAS = ""
+IMAGE_LINGUAS = ""
#IMAGE_LINGUAS = "en-us"
#IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
#ROOTFS_POSTPROCESS_COMMAND += 'install_linguas; '
+IMAGE_FEATURES += "package-management ssh-server-dropbear"
#MAYBE WE WILL NEED THESE ALSO:
-# xorg-minimal-fonts xserver-xorg-multimedia-modules xerver-xorg-utils xrandr
+# xorg-minimal-fonts xserver-xorg-multimedia-modules xerver-xorg-utils
IMAGE_SPLASH = "psplash-angstrom"
PREFERRED_PROVIDER_psplash-support = "psplash-angstrom"
+PREFERRED_PROVIDER_virtual/psplash = "psplash-angstrom"
DISTRO_UPDATE_ALTERNATIVES ??= ""
ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE} ${DISTRO_UPDATE_ALTERNATIVES}", d)}'
-CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd"
+CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd connman-gnome"
CONMANPKGS_libc-uclibc = ""
DEPENDS += "gst-plugins-good gst-plugins-bad gst-plugins-ugly"
# Additional X libs not pulled in by any package \
-# xtrans libxdamage libxvmc libxinerama libxevie \
-
-# Required for starting X but not RDEPEND by the using package \
-# libxcursor \
-
-# glib-2.0 has some additional packages which are not pulled in, let's do this here \
-# gobject-2.0 gmodule-2.0 gthread-2.0 gio-2.0 \
+# xtrans libxevie \
# this would pull in a large amount of gst-plugins, we only add a selected few
# gst-plugins-base-meta \
@@ -51,8 +49,12 @@ IMAGE_INSTALL += " \
${ROOTFS_PKGMANAGE_PKGS} \
timestamp-service \
task-base-extended \
+ task-x11-server\
+ task-x11-utils \
+ \
${IMAGE_SPLASH} \
${XSERVER} \
+ xrandr \
\
libxdamage libxvmc libxinerama \
libxcursor \
@@ -87,12 +89,12 @@ IMAGE_INSTALL += " \
firefox \
flash-plugins \
"
-#libxevie
-# gst-plugin-qtdemux \
-# gst-plugin-mpegdemux \
-include lx.inc
-include trdx-extra.inc
+# gst-plugin-qtdemux
+# gst-plugin-mpegdemux
+
+require lx.inc
+require trdx-extra.inc
IMAGE_DEV_MANAGER = "udev"
IMAGE_INIT_MANAGER = "systemd"
@@ -101,4 +103,4 @@ IMAGE_LOGIN_MANAGER = "tinylogin shadow"
export IMAGE_BASENAME = "LXDE-image"
-inherit image
+inherit core-image
diff --git a/recipes/images/lx.inc b/recipes/images/lx.inc
index 9716522..fce7977 100644
--- a/recipes/images/lx.inc
+++ b/recipes/images/lx.inc
@@ -30,10 +30,10 @@ IMAGE_INSTALL += " \
lxterminal \
lxinput \
"
-# angstrom-task-lxde \
-# task-lxde-xserver \
-# task-lxde-xserver-base \
-# lxappearance-obconf \
-# xkbd \
-# xcursor-themes \
-# policykit-gnome \
+# angstrom-task-lxde
+# task-lxde-xserver
+# task-lxde-xserver-base
+# lxappearance-obconf
+# xkbd
+# xcursor-themes
+# policykit-gnome
diff --git a/recipes/images/trdx-extra.inc b/recipes/images/trdx-extra.inc
index 145e6f5..91ccacf 100644
--- a/recipes/images/trdx-extra.inc
+++ b/recipes/images/trdx-extra.inc
@@ -1,23 +1,17 @@
#additional packages to include in our Toradex images
-#the following builds cross gdb
+#the following builds cross gdb and gdbserver
DEPENDS += "gdb-cross"
-#the gdb recipe provides gdbserver
-DEPENDS += "gdb"
+IMAGE_INSTALL_MACHINE_colibri-t20 = "trdx-odm"
-IMAGE_INSTALL_MACHINE_colibri-t20 += " \
- trdx-odm \
-"
-IMAGE_INSTALL_MACHINE += " \
-"
+IMAGE_INSTALL_MACHINE = ""
-IMAGE-INSTALL += " \
+IMAGE_INSTALL += " \
alsa-utils \
alsa-utils-aplay \
alsa-utils-amixer \
\
- \
aspell \
consolekit \
sqlite3 \
@@ -37,6 +31,8 @@ IMAGE-INSTALL += " \
mtd-utils \
update-modules \
\
+ gpioconfig \
+ tegrastats \
hdparm \
iperf \
memtester \
@@ -50,7 +46,5 @@ IMAGE-INSTALL += " \
\
trdx-oak-sensors \
"
-# tegrastats \
-# gpioconfig \
-# openssl-conf \
-# ntpclient \
+# openssl-conf
+# ntpclient