summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/machine/apalis-imx6.conf2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb4
-rw-r--r--recipes-kernel/linux/linux-toradex-fsl_git.bb2
-rwxr-xr-xrecipes/images/files/library/imx6/update.sh2
4 files changed, 5 insertions, 5 deletions
diff --git a/conf/machine/apalis-imx6.conf b/conf/machine/apalis-imx6.conf
index 08eaa02..80ca71a 100644
--- a/conf/machine/apalis-imx6.conf
+++ b/conf/machine/apalis-imx6.conf
@@ -12,7 +12,7 @@ SOC_FAMILY = "mx6:mx6q"
PREFERRED_PROVIDER_u-boot = "u-boot-toradex-fsl"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-fsl"
PREFERRED_PROVIDER_virtual/kernel = "linux-toradex-fsl"
-KERNEL_DEVICETREE = "imx6q-apalis-eval.dtb imx6q-apalis-eval_v1_0.dtb"
+KERNEL_DEVICETREE = "imx6q-apalis-eval.dtb imx6q-apalis_v1_0-eval.dtb"
KERNEL_IMAGETYPE = "uImage"
PREFERRED_VERSION_xserver-xorg_mx6 = "99:1.14%"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
index af9430f..5604ffe 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
@@ -10,8 +10,8 @@ PR = "r0"
S = "${WORKDIR}/git"
-SRCREV_mx6 = "06ee8db6422e02337242e43b8573359443db59ea"
-SRCBRANCH_mx6 = "2015.04-toradex"
+SRCREV_mx6 = "95868835ab8181591446bc3f24a15bf6fbdfd1f5"
+SRCBRANCH_mx6 = "2015.04-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
#FILESPATHPKG =. "git:"
diff --git a/recipes-kernel/linux/linux-toradex-fsl_git.bb b/recipes-kernel/linux/linux-toradex-fsl_git.bb
index 48dc5c5..cb4f518 100644
--- a/recipes-kernel/linux/linux-toradex-fsl_git.bb
+++ b/recipes-kernel/linux/linux-toradex-fsl_git.bb
@@ -11,7 +11,7 @@ DEPENDS += "lzop-native "
LINUX_VERSION_mx6 = "3.14.28"
-SRCREV_mx6 = "01055e28e5af1d5e309c9eeea19cf012f324dbe8"
+SRCREV_mx6 = "6ef4eef1eb726929d913580b9b24d4f57904dc80"
PR_mx6 = "V2.5b1"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
diff --git a/recipes/images/files/library/imx6/update.sh b/recipes/images/files/library/imx6/update.sh
index 1932804..a484d7a 100755
--- a/recipes/images/files/library/imx6/update.sh
+++ b/recipes/images/files/library/imx6/update.sh
@@ -112,7 +112,7 @@ else
IMAGEFILE=root.ext3
U_BOOT_BINARY=u-boot.imx
U_BOOT_BINARY_IT=u-boot-it.imx
- KERNEL_DEVICETREE="imx6q-apalis-eval.dtb imx6q-apalis-eval_v1_0.dtb"
+ KERNEL_DEVICETREE="imx6q-apalis-eval.dtb imx6q-apalis_v1_0-eval.dtb"
LOCPATH="imx_flash"
# assumed minimal eMMC size [in sectors of 512]
EMMC_SIZE=$(expr 1024 \* 3500 \* 2)