summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python/dont_build_tkinter.patch24
-rw-r--r--recipes-devtools/python/python_2.7.%.bbappend17
2 files changed, 0 insertions, 41 deletions
diff --git a/recipes-devtools/python/python/dont_build_tkinter.patch b/recipes-devtools/python/python/dont_build_tkinter.patch
deleted file mode 100644
index bdd47a8..0000000
--- a/recipes-devtools/python/python/dont_build_tkinter.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-_tkinter module needs tk module along with tcl.
-Force python to not be built with _tkinter.
-
-Upstream-Status: Inappropriate [distribution]
-
-Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-
---- Python-2.7.9/setup.py.orig 2015-12-20 16:56:24.580951972 +0100
-+++ Python-2.7.9/setup.py 2015-12-20 17:00:34.524083526 +0100
-@@ -1762,10 +1762,11 @@
- self.extensions.extend(exts)
-
- # Call the method for detecting whether _tkinter can be compiled
-- self.detect_tkinter(inc_dirs, lib_dirs)
-+ # disable detection of tcl/tk and thus don't build python with _tkinter
-+ #self.detect_tkinter(inc_dirs, lib_dirs)
-
-- if '_tkinter' not in [e.name for e in self.extensions]:
-- missing.append('_tkinter')
-+ #if '_tkinter' not in [e.name for e in self.extensions]:
-+ # missing.append('_tkinter')
-
- ## # Uncomment these lines if you want to play with xxmodule.c
- ## ext = Extension('xx', ['xxmodule.c'])
diff --git a/recipes-devtools/python/python_2.7.%.bbappend b/recipes-devtools/python/python_2.7.%.bbappend
deleted file mode 100644
index bc5c05e..0000000
--- a/recipes-devtools/python/python_2.7.%.bbappend
+++ /dev/null
@@ -1,17 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/python:"
-
-SRC_URI_remove = "file://avoid_warning_about_tkinter.patch"
-
-PACKAGECONFIG ?= ""
-
-PACKAGECONFIG[tkinter] = ",,tk"
-PACKAGECONFIG_remove_class-native = "tkinter"
-PACKAGECONFIG_remove_class-nativesdk = "tkinter"
-RDEPENDS_${PN}-tkinter_append += "${@bb.utils.contains('PACKAGECONFIG', 'tkinter', 'tcl tk', '', d)}"
-SRC_URI += " ${@bb.utils.contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)}"
-python __anonymous() {
- if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS', True):
- if 'tkinter' in d.getVar('PACKAGECONFIG', True):
- bb.error('Python PACKAGECONFIG tkinter requires tk provided by' \
- 'meta-oe layer but the layer is not available.')
-}