summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend2
-rw-r--r--recipes-images/images/tdx-extra.inc9
2 files changed, 6 insertions, 5 deletions
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
index a038011..855bb4e 100644
--- a/recipes-core/base-files/base-files_3.0.14.bbappend
+++ b/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -10,3 +10,5 @@ do_install_append () {
install -m 0644 ${WORKDIR}/disable_systemd_coloroutput.sh ${D}${sysconfdir}/profile.d/
install -m 0644 ${WORKDIR}/x11-display-var.sh ${D}${sysconfdir}/profile.d/
}
+
+BASEFILESISSUEINSTALL = ""
diff --git a/recipes-images/images/tdx-extra.inc b/recipes-images/images/tdx-extra.inc
index 843ff47..ca4f684 100644
--- a/recipes-images/images/tdx-extra.inc
+++ b/recipes-images/images/tdx-extra.inc
@@ -6,13 +6,12 @@ COPY_LIC_MANIFEST ?= "1"
COPY_LIC_DIRS ?= "1"
add_rootfs_version () {
- echo -n "${IMAGE_NAME} ${PV}" >> ${IMAGE_ROOTFS}/etc/issue
- echo " ${TDX_VERDATE}" | sed 's/-//' >>${IMAGE_ROOTFS}/etc/issue
- echo "" >> ${IMAGE_ROOTFS}/etc/issue
+ printf "${DISTRO_NAME} ${DISTRO_VERSION} (${DISTRO_CODENAME}) \\\n \\\l\n" > ${IMAGE_ROOTFS}/etc/issue
+ printf "${DISTRO_NAME} ${DISTRO_VERSION} (${DISTRO_CODENAME}) %%h\n" > ${IMAGE_ROOTFS}/etc/issue.net
+ printf "${IMAGE_NAME}\n\n" >> ${IMAGE_ROOTFS}/etc/issue
+ printf "${IMAGE_NAME}\n\n" >> ${IMAGE_ROOTFS}/etc/issue.net
}
-PV = "${TDX_VER_PACKAGE_MIN}"
-
# add the rootfs version to the welcome banner
ROOTFS_POSTPROCESS_COMMAND += " add_rootfs_version;"