summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-cinematicexperience_1.0.bb9
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb12
2 files changed, 19 insertions, 2 deletions
diff --git a/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-cinematicexperience_1.0.bb b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-cinematicexperience_1.0.bb
new file mode 100644
index 0000000..f36556b
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-cinematicexperience_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be launched right after weston started
+
+INITIAL_APP_PKGS ?= "weston"
+INITIAL_PATH ?= ""
+APPLICATION_ENVIRONMENT ?= '\"QT_QPA_PLATFORM=wayland-egl\"'
+WAYLAND_APPLICATION ?= "/usr/share/cinematicexperience-1.0/Qt5_CinematicExperience --fullscreen"
+
+require wayland-app-launch.inc
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index 02b2b44..768fcb4 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -14,12 +14,20 @@ IMAGE_FEATURES += " \
'', d), d)} \
"
+APP_LAUNCH_WAYLAND ?= "wayland-qtdemo-launch-cinematicexperience"
+APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
+
+APP_LAUNCH_X11_colibri-imx6ull ?= "x-window-qtsmarthome"
+APP_LAUNCH_X11_colibri-imx6 ?= "x-window-qtsmarthome"
+APP_LAUNCH_X11_mx7 ?= "x-window-qtsmarthome"
+APP_LAUNCH_X11_apalis-tk1 ?= "x-window-xterm"
+
IMAGE_INSTALL += " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
- 'weston weston-init weston-examples wayland-terminal-launch', '', d)} \
+ 'weston weston-init weston-examples ${APP_LAUNCH_WAYLAND}', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
'weston-xwayland xterm', \
- bb.utils.contains('DISTRO_FEATURES', 'x11', 'x-window-xterm', '', d), d)} \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', '${APP_LAUNCH_X11}', '', d), d)} \
\
packagegroup-tdx-cli \
packagegroup-tdx-graphical \