summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/spidev-test/spidev-test.bb14
1 files changed, 3 insertions, 11 deletions
diff --git a/recipes-devtools/spidev-test/spidev-test.bb b/recipes-devtools/spidev-test/spidev-test.bb
index 3e0b1e1..b9d9ad9 100644
--- a/recipes-devtools/spidev-test/spidev-test.bb
+++ b/recipes-devtools/spidev-test/spidev-test.bb
@@ -1,24 +1,16 @@
SUMMARY = "The Linux kernels spidev-test programm"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${STAGING_KERNEL_DIR}/${KERNELPATH};endline=1;md5=fcab174c20ea2e2bc0be64b493708266"
PACKAGE_ARCH = "${MACHINE_ARCH}"
S = "${WORKDIR}"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
-# the spidev_test.c example got moved to tools/spi/ starting with
-# the v.4.5.y kernel
KERNELPATH = "tools/spi/spidev_test.c"
-KERNELPATH-OLD = "Documentation/spi/spidev_test.c"
do_compile () {
- if [ -f "${STAGING_KERNEL_DIR}/${KERNELPATH}" ]
- then
- ${CC} ${LDFLAGS} ${STAGING_KERNEL_DIR}/${KERNELPATH} -o spidev_test
- else
- ${CC} ${LDFLAGS} ${STAGING_KERNEL_DIR}/${KERNELPATH-OLD} -o spidev_test
- fi
+ ${CC} ${LDFLAGS} ${STAGING_KERNEL_DIR}/${KERNELPATH} -o spidev_test
}
do_install () {