summaryrefslogtreecommitdiff
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf8
1 files changed, 8 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 3f070c0..d80ef67 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -8,6 +8,14 @@ BBFILE_COLLECTIONS += "toradex-demos"
BBFILE_PATTERN_toradex-demos = "^${LAYERDIR}/"
BBFILE_PRIORITY_toradex-demos = "90"
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# Add layer-specific bb files too
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+
LAYERDEPENDS_toradex-demos = " \
core \
openembedded-layer gnome-layer multimedia-layer networking-layer \