summaryrefslogtreecommitdiff
path: root/recipes-browser/chromium/chromium_24.0.1312.52.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-browser/chromium/chromium_24.0.1312.52.bbappend')
-rw-r--r--recipes-browser/chromium/chromium_24.0.1312.52.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-browser/chromium/chromium_24.0.1312.52.bbappend b/recipes-browser/chromium/chromium_24.0.1312.52.bbappend
new file mode 100644
index 0000000..8998254
--- /dev/null
+++ b/recipes-browser/chromium/chromium_24.0.1312.52.bbappend
@@ -0,0 +1,23 @@
+PRINC = "1"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
+
+EXTRA_OEGYP_prepend = "-DUSE_EABI_HARDFLOAT=1"
+
+SRC_URI += " \
+ file://chromium_arm_build.patch \
+ file://h264_enablement.patch \
+"
+
+FILES_${PN} += " \
+ ${libdir}/libOmxCore.so
+"
+
+#we have a symlinks ending in .so, skip QA ldflags for this package
+INSANE_SKIP_${PN} = "dev-so ldflags"
+
+do_install_append () {
+ #make a symlink with the standard soname of the OpenMax component
+ install -d ${D}/${libdir}
+ ln -s libnvomx.so ${D}/${libdir}/libOmxCore.so
+}