summaryrefslogtreecommitdiff
path: root/recipes-devtools/mmc/mmc-utils-cos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/mmc/mmc-utils-cos_git.bb')
-rw-r--r--recipes-devtools/mmc/mmc-utils-cos_git.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/recipes-devtools/mmc/mmc-utils-cos_git.bb b/recipes-devtools/mmc/mmc-utils-cos_git.bb
index 54dcaca..5cc27ad 100644
--- a/recipes-devtools/mmc/mmc-utils-cos_git.bb
+++ b/recipes-devtools/mmc/mmc-utils-cos_git.bb
@@ -1,18 +1,21 @@
-DESCRIPTION = "Userspace tools for MMC/SD devices"
-HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/"
+SUMMARY = "Userspace tools for MMC/SD devices (Downstream version of Chromium OS Project)"
+HOMEPAGE = "http://chromium.googlesource.com/chromiumos/third_party/mmc-utils.git"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=17;md5=d7747fc87f1eb22b946ef819969503f0"
-BRANCH ?= "master"
-SRCREV = "eb1cd019c6ad425633a509ab3578e59d5c9ebbc5"
+SRCBRANCH ?= "master"
+SRCREV = "bcc3e2e4246431be511be3959a11cd9733bedd29"
PV = "0.1"
-SRC_URI = "git://chromium.googlesource.com/chromiumos/third_party/mmc-utils.git;protocol=https;branch=${BRANCH} \
- file://0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch"
+SRC_URI = "git://chromium.googlesource.com/chromiumos/third_party/mmc-utils.git;protocol=https;branch=${SRCBRANCH}"
S = "${WORKDIR}/git"
+CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
+CFLAGS_append_mips64 = " -D__SANE_USERSPACE_TYPES__"
+CFLAGS_append_mips64n32 = " -D__SANE_USERSPACE_TYPES__"
+
do_install() {
install -d ${D}${bindir}
install -m 0755 mmc ${D}${bindir}