summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/opkg/opkg/opkg-configure.service17
-rw-r--r--recipes-devtools/opkg/opkg_0.3.3.bbappend1
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/opkg/opkg/opkg-configure.service b/recipes-devtools/opkg/opkg/opkg-configure.service
new file mode 100644
index 0000000..432c3dd
--- /dev/null
+++ b/recipes-devtools/opkg/opkg/opkg-configure.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=Opkg first boot configure
+DefaultDependencies=no
+After=systemd-remount-fs.service systemd-tmpfiles-setup.service tmp.mount
+Before=sysinit.target
+
+[Service]
+Type=oneshot
+EnvironmentFile=-@SYSCONFDIR@/default/postinst
+ExecStart=-@BASE_BINDIR@/sh -c " if [ $POSTINST_LOGGING = '1' ]; then @BINDIR@/opkg configure > $LOGFILE 2>&1; else @BINDIR@/opkg configure; fi"
+ExecStartPost=@BASE_BINDIR@/systemctl --no-reload disable opkg-configure.service
+StandardOutput=syslog
+RemainAfterExit=No
+
+[Install]
+WantedBy=basic.target
+WantedBy=sysinit.target
diff --git a/recipes-devtools/opkg/opkg_0.3.3.bbappend b/recipes-devtools/opkg/opkg_0.3.3.bbappend
new file mode 100644
index 0000000..49e7305
--- /dev/null
+++ b/recipes-devtools/opkg/opkg_0.3.3.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/opkg:"