summaryrefslogtreecommitdiff
path: root/recipes-images/images/graphical-tdx-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-images/images/graphical-tdx-image.bb')
-rw-r--r--recipes-images/images/graphical-tdx-image.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-images/images/graphical-tdx-image.bb b/recipes-images/images/graphical-tdx-image.bb
new file mode 100644
index 0000000..b472701
--- /dev/null
+++ b/recipes-images/images/graphical-tdx-image.bb
@@ -0,0 +1,26 @@
+require console-tdx-image.bb
+
+SUMMARY = "Toradex Embedded Linux Graphical Image"
+SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
+DESCRIPTION = "Image with a graphical interface, either using weston or X11"
+
+LICENSE = "MIT"
+
+#Prefix to the resulting deployable tarball name
+export IMAGE_BASENAME = "Graphical-Image"
+
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
+
+IMAGE_FEATURES += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
+ '', d), d)} \
+"
+
+IMAGE_INSTALL += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
+ 'weston weston-init weston-examples wayland-terminal-launch', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
+ 'weston-xwayland xterm', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x-window-xterm', '', d), d)} \
+"