summaryrefslogtreecommitdiff
path: root/recipes-images/images/tdx-updater_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-images/images/tdx-updater_1.0.bb')
-rw-r--r--recipes-images/images/tdx-updater_1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-images/images/tdx-updater_1.0.bb b/recipes-images/images/tdx-updater_1.0.bb
new file mode 100644
index 0000000..bee6a35
--- /dev/null
+++ b/recipes-images/images/tdx-updater_1.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Toradex legacy updater host files"
+DESCRIPTION = "Deploys files used by tdx-image-fstype.inc to create \
+the legacy update tarball."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://update file://library"
+
+do_install () {
+ install -d ${D}/${datadir}/update
+ cp -Lr ${WORKDIR}/update/* ${D}/${datadir}/update/
+}
+
+FILES_${PN} += "${datadir}/update"
+PACKAGE_ARCH = "${MACHINE_ARCH}"