summaryrefslogtreecommitdiff
path: root/recipes-images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-images')
-rw-r--r--recipes-images/images/angstrom-lxde-image.bb11
-rw-r--r--recipes-images/images/angstrom-qt-x11-image.bb10
-rw-r--r--recipes-images/images/angstrom-qt5-x11-image.bb10
-rw-r--r--recipes-images/images/console-tdx-image.bb1
-rw-r--r--recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/flash_blk.scr15
-rw-r--r--recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/flash_eth.scr15
l---------recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/fwd_blk.scr1
l---------recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/fwd_eth.scr1
l---------recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/mk-u-boot-scripts.sh1
-rwxr-xr-xrecipes-images/images/files/colibri-imx6ull/update.sh222
-rw-r--r--recipes-images/images/qt4e-demo-image.bb1
-rw-r--r--recipes-images/images/tdx-extra.inc14
-rw-r--r--recipes-images/images/tdx-image-fstype.inc20
13 files changed, 315 insertions, 7 deletions
diff --git a/recipes-images/images/angstrom-lxde-image.bb b/recipes-images/images/angstrom-lxde-image.bb
index b876e3c..ae11273 100644
--- a/recipes-images/images/angstrom-lxde-image.bb
+++ b/recipes-images/images/angstrom-lxde-image.bb
@@ -9,6 +9,7 @@ IMAGE_NAME_apalis-t30 = "Apalis-T30_${IMAGE_BASENAME}"
IMAGE_NAME_apalis-tk1 = "Apalis-TK1_${IMAGE_BASENAME}"
IMAGE_NAME_apalis-tk1-mainline = "Apalis-TK1-Mainline_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx6 = "Colibri-iMX6_${IMAGE_BASENAME}"
+IMAGE_NAME_colibri-imx6ull = "Colibri-iMX6ULL_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx7 = "Colibri-iMX7_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-pxa = "Colibri-PXA_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-t20 = "Colibri-T20_${IMAGE_BASENAME}"
@@ -88,13 +89,16 @@ GSTREAMER = " \
# gst-plugins-ugly-asf \
#"
-GSTREAMER_append_mx6 = " \
+GSTREAMER_MX6QDL = " \
gstreamer1.0-plugins-base-ximagesink \
gstreamer1.0-plugins-imx \
imx-gst1.0-plugin \
imx-gst1.0-plugin-gplay \
imx-gst1.0-plugin-grecorder \
"
+GSTREAMER_append_mx6q = "${GSTREAMER_MX6QDL}"
+GSTREAMER_append_mx6dl = "${GSTREAMER_MX6QDL}"
+
GSTREAMER_append_mx7 = " \
gstreamer1.0-plugins-base-ximagesink \
imx-gst1.0-plugin \
@@ -215,7 +219,7 @@ IMAGE_INSTALL_append_tegra124m = " \
\
packagegroup-snapd \
"
-IMAGE_INSTALL_append_mx6 = " \
+IMAGE_INSTALL_MX6QDL = " \
gpio-tool \
packagegroup-fsl-gpu-libs \
libopencl-mx6 \
@@ -225,6 +229,9 @@ IMAGE_INSTALL_append_mx6 = " \
\
packagegroup-snapd \
"
+IMAGE_INSTALL_append_mx6q = "${IMAGE_INSTALL_MX6QDL}"
+IMAGE_INSTALL_append_mx6dl = "${IMAGE_INSTALL_MX6QDL}"
+
IMAGE_INSTALL_append_mx7 = " \
gpio-tool \
gnome-disk-utility \
diff --git a/recipes-images/images/angstrom-qt-x11-image.bb b/recipes-images/images/angstrom-qt-x11-image.bb
index 39c7119..8d5c501 100644
--- a/recipes-images/images/angstrom-qt-x11-image.bb
+++ b/recipes-images/images/angstrom-qt-x11-image.bb
@@ -9,6 +9,7 @@ IMAGE_NAME_apalis-t30 = "Apalis-T30_${IMAGE_BASENAME}"
IMAGE_NAME_apalis-tk1 = "Apalis-TK1_${IMAGE_BASENAME}"
IMAGE_NAME_apalis-tk1-mainline = "Apalis-TK1-Mainline_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx6 = "Colibri-iMX6_${IMAGE_BASENAME}"
+IMAGE_NAME_colibri-imx6ull = "Colibri-iMX6ULL_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx7 = "Colibri-iMX7_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-pxa = "Colibri-PXA_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-t20 = "Colibri-T20_${IMAGE_BASENAME}"
@@ -78,13 +79,16 @@ GSTREAMER = " \
# gst-plugins-ugly-asf \
#"
-GSTREAMER_append_mx6 = " \
+GSTREAMER_MX6QDL = " \
gstreamer1.0-plugins-base-ximagesink \
gstreamer1.0-plugins-imx \
imx-gst1.0-plugin \
imx-gst1.0-plugin-gplay \
imx-gst1.0-plugin-grecorder \
"
+GSTREAMER_append_mx6q = "${GSTREAMER_MX6QDL}"
+GSTREAMER_append_mx6dl = "${GSTREAMER_MX6QDL}"
+
GSTREAMER_append_mx7 = " \
gstreamer1.0-plugins-base-ximagesink \
imx-gst1.0-plugin \
@@ -224,11 +228,13 @@ IMAGE_INSTALL_append_tegra124m = " \
tiff \
xvinfo \
"
-IMAGE_INSTALL_append_mx6 = " \
+IMAGE_INSTALL_MX6QDL = " \
packagegroup-fsl-gpu-libs \
libopencl-mx6 \
eglinfo-x11 \
"
+IMAGE_INSTALL_append_mx6q = "${IMAGE_INSTALL_MX6QDL}"
+IMAGE_INSTALL_append_mx6dl = "${IMAGE_INSTALL_MX6QDL}"
# Packages which might no longer exist
RRECOMMENDS_${PN} += "xserver-xorg-multimedia-modules"
diff --git a/recipes-images/images/angstrom-qt5-x11-image.bb b/recipes-images/images/angstrom-qt5-x11-image.bb
index 40456b9..40e2206 100644
--- a/recipes-images/images/angstrom-qt5-x11-image.bb
+++ b/recipes-images/images/angstrom-qt5-x11-image.bb
@@ -13,6 +13,7 @@ IMAGE_NAME_apalis-t30 = "Apalis-T30_${IMAGE_BASENAME}"
IMAGE_NAME_apalis-tk1 = "Apalis-TK1_${IMAGE_BASENAME}"
IMAGE_NAME_apalis-tk1-mainline = "Apalis-TK1-Mainline_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx6 = "Colibri-iMX6_${IMAGE_BASENAME}"
+IMAGE_NAME_colibri-imx6ull = "Colibri-iMX6ULL_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx7 = "Colibri-iMX7_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-pxa = "Colibri-PXA_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-t20 = "Colibri-T20_${IMAGE_BASENAME}"
@@ -84,13 +85,16 @@ GSTREAMER = " \
# gst-plugins-ugly-asf \
#"
-GSTREAMER_append_mx6 = " \
+GSTREAMER_MX6QDL = " \
gstreamer1.0-plugins-base-ximagesink \
gstreamer1.0-plugins-imx \
imx-gst1.0-plugin \
imx-gst1.0-plugin-gplay \
imx-gst1.0-plugin-grecorder \
"
+GSTREAMER_append_mx6q = "${GSTREAMER_MX6QDL}"
+GSTREAMER_append_mx6dl = "${GSTREAMER_MX6QDL}"
+
GSTREAMER_append_mx7 = " \
gstreamer1.0-plugins-base-ximagesink \
imx-gst1.0-plugin \
@@ -200,11 +204,13 @@ IMAGE_INSTALL_append_tegra124m = " \
tiff \
xvinfo \
"
-IMAGE_INSTALL_append_mx6 = " \
+IMAGE_INSTALL_MX6QDL = " \
packagegroup-fsl-gpu-libs \
libopencl-mx6 \
eglinfo-x11 \
"
+IMAGE_INSTALL_append_mx6q = "${IMAGE_INSTALL_MX6QDL}"
+IMAGE_INSTALL_append_mx6dl = "${IMAGE_INSTALL_MX6QDL}"
# Packages which might no longer exist
RRECOMMENDS_${PN} += "xserver-xorg-multimedia-modules"
diff --git a/recipes-images/images/console-tdx-image.bb b/recipes-images/images/console-tdx-image.bb
index 050f2cb..db6d347 100644
--- a/recipes-images/images/console-tdx-image.bb
+++ b/recipes-images/images/console-tdx-image.bb
@@ -9,6 +9,7 @@ IMAGE_NAME_apalis-t30 = "Apalis-T30_${IMAGE_BASENAME}"
IMAGE_NAME_apalis-tk1 = "Apalis-TK1_${IMAGE_BASENAME}"
IMAGE_NAME_apalis-tk1-mainline = "Apalis-TK1-Mainline_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx6 = "Colibri-iMX6_${IMAGE_BASENAME}"
+IMAGE_NAME_colibri-imx6ull = "Colibri-iMX6ULL_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx7 = "Colibri-iMX7_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-pxa = "Colibri-PXA_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-t20 = "Colibri-T20_${IMAGE_BASENAME}"
diff --git a/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/flash_blk.scr b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/flash_blk.scr
new file mode 100644
index 0000000..63862d0
--- /dev/null
+++ b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/flash_blk.scr
@@ -0,0 +1,15 @@
+setenv create_bcb 'nand erase.part mx6ull-bcb && writebcb 80000 200000'
+setenv recreate_bcb 'nand read ${loadaddr} 0x800 0x800 && run create_bcb && nand write ${loadaddr} 0x800 0x800'
+
+setenv prepare_kernel_fdt 'ubi create kernel 0x800000 static && ubi create dtb 0x20000 static'
+setenv prepare_rootfs 'ubi create rootfs 0 dynamic'
+setenv prepare_ubi 'ubi part ubi && if ubi check rootfs; then else run prepare_kernel_fdt && && run prepare_rootfs; fi'
+
+setenv update_uboot 'fatload ${interface} 0:1 ${loadaddr} ${board_name}/u-boot-nand.imx && nand erase.part u-boot1 && nand write ${loadaddr} u-boot1 ${filesize} && nand erase.part u-boot2 && nand write ${loadaddr} u-boot2 ${filesize}'
+setenv update_kernel 'fatload ${interface} 0:1 ${loadaddr} ${board_name}/zImage && ubi write ${loadaddr} kernel ${filesize}'
+setenv update_fdt 'fatload ${interface} 0:1 ${loadaddr} ${board_name}/i${soc}ull-colibri-${fdt_board}.dtb && ubi write ${loadaddr} dtb ${filesize}'
+setenv update_rootfs 'fatload ${interface} 0:1 ${loadaddr} ${board_name}/ubifs.img && ubi write ${loadaddr} rootfs ${filesize}'
+
+setenv update 'mtdparts default && run update_uboot && run prepare_ubi && run update_kernel && run update_fdt && run update_rootfs && reset'
+
+echo 'enter "run update" to update the entire module'
diff --git a/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/flash_eth.scr b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/flash_eth.scr
new file mode 100644
index 0000000..a4b6cba
--- /dev/null
+++ b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/flash_eth.scr
@@ -0,0 +1,15 @@
+setenv create_bcb 'nand erase.part mx6ull-bcb && writebcb 80000 200000'
+setenv recreate_bcb 'nand read ${loadaddr} 0x800 0x800 && run create_bcb && nand write ${loadaddr} 0x800 0x800'
+
+setenv prepare_kernel_fdt 'ubi create kernel 0x800000 static && ubi create dtb 0x20000 static'
+setenv prepare_rootfs 'ubi create rootfs 0 dynamic'
+setenv prepare_ubi 'ubi part ubi && if ubi check rootfs; then else run prepare_kernel_fdt && && run prepare_rootfs; fi'
+
+setenv update_uboot 'tftpboot ${loadaddr} ${board_name}/u-boot-nand.imx && nand erase.part u-boot1 && nand write ${loadaddr} u-boot1 ${filesize} && nand erase.part u-boot2 && nand write ${loadaddr} u-boot2 ${filesize}'
+setenv update_kernel 'tftpboot ${loadaddr} ${board_name}/zImage && ubi write ${loadaddr} kernel ${filesize}'
+setenv update_fdt 'tftpboot ${loadaddr} ${board_name}/i${soc}ull-colibri-${fdt_board}.dtb && ubi write ${loadaddr} dtb ${filesize}'
+setenv update_rootfs 'tftpboot ${loadaddr} ${board_name}/ubifs.img && ubi write ${loadaddr} rootfs ${filesize}'
+
+setenv update 'mtdparts default && run update_uboot && run prepare_ubi && run update_kernel && run update_fdt && run update_rootfs && reset'
+
+echo 'enter "run update" to update the entire module'
diff --git a/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/fwd_blk.scr b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/fwd_blk.scr
new file mode 120000
index 0000000..5954646
--- /dev/null
+++ b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/fwd_blk.scr
@@ -0,0 +1 @@
+../../library/fwd_blk.scr \ No newline at end of file
diff --git a/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/fwd_eth.scr b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/fwd_eth.scr
new file mode 120000
index 0000000..decc214
--- /dev/null
+++ b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/fwd_eth.scr
@@ -0,0 +1 @@
+../../library/fwd_eth.scr \ No newline at end of file
diff --git a/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/mk-u-boot-scripts.sh b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/mk-u-boot-scripts.sh
new file mode 120000
index 0000000..ce71dbd
--- /dev/null
+++ b/recipes-images/images/files/colibri-imx6ull/colibri-imx6ull_bin/mk-u-boot-scripts.sh
@@ -0,0 +1 @@
+../../library/mk-u-boot-scripts.sh \ No newline at end of file
diff --git a/recipes-images/images/files/colibri-imx6ull/update.sh b/recipes-images/images/files/colibri-imx6ull/update.sh
new file mode 100755
index 0000000..76339c5
--- /dev/null
+++ b/recipes-images/images/files/colibri-imx6ull/update.sh
@@ -0,0 +1,222 @@
+#! /bin/sh
+# Prepare files needed for flashing a Colibri iMX6ULL module and
+# copy them to a convenient location for using from a running U-Boot
+
+set -e
+
+Flash()
+{
+ echo "To flash the Colibri iMX6ULL module a running U-Boot is required. Boot the"
+ echo "module to the U-Boot prompt and"
+ echo ""
+ echo "insert the SD card, USB flash drive or when using TFTP connect Ethernet only"
+ echo "and enter:"
+ echo "'run setupdate'"
+ echo ""
+ echo "then to update all components enter:"
+ echo "'run update'"
+ echo ""
+ echo "Alternatively, to update U-Boot enter:"
+ echo "'run update_uboot'"
+ echo "to update a component stored in UBI enter:"
+ echo "'run prepare_ubi'"
+ echo "followed by one of:"
+ echo "'run update_kernel'"
+ echo "'run update_fdt'"
+ echo "'run update_rootfs'"
+ echo ""
+ echo ""
+ echo "If you don't have a working U-Boot anymore, connect your PC to the module's"
+ echo "USB client port, bring the module into the serial download mode and start the update.sh"
+ echo "script with the -d option. This will copy U-Boot into the module's RAM and"
+ echo "execute it."
+ echo ""
+ echo "Then use the following command to get U-Boot running:"
+ echo "'./update.sh -d'"
+ echo ""
+ echo "Next, recreate the Boot Configuration Block and the Toradex Config Block:"
+ echo "'run setupdate'"
+ echo "'run update_uboot'"
+ echo "'run create_bcb'"
+ echo "'cfgblock create'"
+}
+
+Usage()
+{
+ echo ""
+ echo "Prepares and copies files for flashing internal NAND of Colibri iMX6ULL"
+ echo ""
+ echo "The recommended way is to copy the files on a SD card or USB flash drive."
+ echo "The script format_sd.sh may be used to format the SD card."
+ echo ""
+ echo "The flash step requires a running U-Boot on the target. Either one already"
+ echo "flashed on the NAND or downloaded using serial downloader (argument -d)."
+ echo ""
+ echo "-d : use a USB connection to copy/execute U-Boot to/from module's RAM"
+ echo "-f : flash instructions"
+ echo "-h : prints this message"
+ echo "-m : module type: 0: autodetect from ./rootfs/etc/issues (default)"
+ echo " 1: Colibri iMX6ULL"
+ echo "-o directory : output directory"
+ echo ""
+ echo "Example \"./update.sh -o /media/KERNEL/\" copies the required files to SD card"
+ echo ""
+ echo "*** For detailed recovery/update procedures, refer to the following website: ***"
+ echo "http://developer.toradex.com/knowledge-base/flashing-embedded-linux-to-imx7-modules"
+ echo ""
+}
+
+# initialise options
+KERNEL_DEVICETREE="imx6ull-colibri-eval-v3.dtb"
+KERNEL_IMAGETYPE="zImage"
+MODTYPE_DETECT=0
+
+# NAND parameters
+BLOCK=124KiB
+MAXLEB=8112
+PAGE=2KiB
+
+OUT_DIR=""
+UBOOT_RECOVERY=0
+
+while getopts "dfhm:o:" Option ; do
+ case $Option in
+ d) UBOOT_RECOVERY=1
+ ;;
+ f) Flash
+ exit 0
+ ;;
+ h) Usage
+ exit 0
+ ;;
+ m) MODTYPE_DETECT=$OPTARG
+ ;;
+ o) OUT_DIR=$OPTARG
+ ;;
+ esac
+done
+
+if [ "$OUT_DIR" = "" ] && [ "$UBOOT_RECOVERY" = "0" ] ; then
+ Usage
+ exit 1
+fi
+
+# is OUT_DIR an existing directory?
+if [ ! -d "$OUT_DIR" ] && [ "$UBOOT_RECOVERY" = "0" ] ; then
+ echo "$OUT_DIR" "does not exist, exiting"
+ exit 1
+fi
+
+case $MODTYPE_DETECT in
+ 0) # auto detect MODTYPE from rootfs directory
+ if [ -f rootfs/etc/issue ] ; then
+ CNT=`grep -c "MX6ULL" rootfs/etc/issue || true`
+ if [ "$CNT" -ge 1 ] ; then
+ echo "Colibri iMX6ULL rootfs detected"
+ MODTYPE=colibri-imx6ull
+ fi
+ fi
+ if [ -e $MODTYPE ] ; then
+ echo "can not detect module type from ./rootfs/etc/issue"
+ echo "please specify the module type with the -m parameter"
+ echo "see help: '$ ./update.sh -h'"
+ echo "exiting"
+ exit 1
+ fi
+ ;;
+ 1) MODTYPE=colibri-imx6ull
+ echo "Colibri iMX6ULL rootfs specified"
+ ;;
+ *) echo "-m paramter specifies an unknown value"
+ exit 1
+ ;;
+esac
+
+case "$MODTYPE" in
+ "colibri-imx6ull")
+ IMAGEFILE=ubifs.img
+ LOCPATH="imx_flash"
+ OUT_DIR="$OUT_DIR/colibri-imx6ull"
+ ;;
+ *) echo "script internal error, unknown module type set"
+ exit 1
+ ;;
+esac
+
+BINARIES=${MODTYPE}_bin
+
+#is only U-Boot to be copied to RAM?
+if [ "$UBOOT_RECOVERY" -eq 1 ] ; then
+ echo "Put the module in recovery mode and press [ENTER]..."
+ read RESULT
+ sudo ${LOCPATH}/imx_usb ${BINARIES}/u-boot.imx
+ exit
+fi
+
+#sanity check for correct untared rootfs
+DEV_OWNER=`ls -ld rootfs/dev | awk '{print $3}'`
+if [ "${DEV_OWNER}x" != "rootx" ]
+then
+ printf "rootfs/dev is not owned by root, but it should!\n"
+ printf "\033[1mPlease unpack the tarball with root rights.\033[0m\n"
+ printf "e.g. sudo tar xjvf Colibri-iMX6ULL_LXDE-Image_2.7b4-20171001.tar.bz2\n"
+ exit 1
+fi
+
+#sanity check, can we execute mkfs.ubifs, e.g. see the help text?
+CNT=`sudo $LOCPATH/mkfs.ubifs -h | grep -c space-fixup || true`
+if [ "$CNT" -eq 0 ] ; then
+ echo "The program mkfs.ubifs can not be executed or does not provide --space-fixup"
+ echo "option."
+ echo "Are you on a 64bit Linux host without installed 32bit execution environment?"
+ printf "\033[1mPlease install e.g. ia32-libs on 64-bit Ubuntu\033[0m"
+ printf "\033[1mMaybe others are needed e.g. liblzo2:i386 on 64-bit Ubuntu\033[0m"
+ exit 1
+fi
+
+#Install trap to write a sensible message in case any of the commands below
+#exit premature...
+trap '{ printf "\033[31mScript aborted unexpectedly...\033[0m\n"; }' EXIT
+
+# Prepare full flashing
+sudo $LOCPATH/mkfs.ubifs --space-fixup -c ${MAXLEB} -e ${BLOCK} -m ${PAGE} -o ${BINARIES}/${IMAGEFILE} -r rootfs/ -v
+
+echo ""
+echo "UBI image of root file system generated, copying data to target folder..."
+
+#make a file with the used versions for U-Boot, kernel and rootfs
+sudo touch ${BINARIES}/versions.txt
+sudo chmod ugo+w ${BINARIES}/versions.txt
+echo "Component Versions" > ${BINARIES}/versions.txt
+basename "`readlink -e ${BINARIES}/u-boot.imx`" >> ${BINARIES}/versions.txt
+ROOTFSVERSION=`grep MX6 rootfs/etc/issue || echo "Version Unknown"`
+echo "Rootfs ${ROOTFSVERSION}" >> ${BINARIES}/versions.txt
+
+#create subdirectory for this module type
+sudo mkdir -p "$OUT_DIR"
+
+# Copy device tree file
+COPIED=false
+if test -n "${KERNEL_DEVICETREE}"; then
+ for DTB_FILE in ${KERNEL_DEVICETREE}; do
+ if [ -e "${BINARIES}/${KERNEL_IMAGETYPE}-${DTB_FILE}" ]; then
+ sudo cp ${BINARIES}/${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${DTB_FILE} "$OUT_DIR/${DTB_FILE}"
+ COPIED=true
+ fi
+ done
+ [ $COPIED = true ] || { echo "Did not find the devicetrees from KERNEL_DEVICETREE, ${KERNEL_DEVICETREE}. Aborting."; exit 1; }
+fi
+
+#copy to $OUT_DIR
+sudo cp ${BINARIES}/u-boot-nand.imx ${BINARIES}/zImage ${BINARIES}/ubifs.img ${BINARIES}/flash*.img ${BINARIES}/versions.txt "$OUT_DIR"
+sudo cp ${BINARIES}/fwd_blk.img "$OUT_DIR/../flash_blk.img"
+sudo cp ${BINARIES}/fwd_eth.img "$OUT_DIR/../flash_eth.img"
+#cleanup intermediate files
+sudo rm ${BINARIES}/ubifs.img ${BINARIES}/versions.txt
+sync
+
+#Remove trap and report success!
+trap - EXIT
+printf "\033[32mSuccessfully copied data to target folder.\033[0m\n\n"
+
+Flash
diff --git a/recipes-images/images/qt4e-demo-image.bb b/recipes-images/images/qt4e-demo-image.bb
index a17968a..22193db 100644
--- a/recipes-images/images/qt4e-demo-image.bb
+++ b/recipes-images/images/qt4e-demo-image.bb
@@ -4,6 +4,7 @@ LICENSE = "MIT"
#start of the resulting deployable tarball name
export IMAGE_BASENAME = "Qt4e-Image"
+IMAGE_NAME_colibri-imx6ull = "Colibri-iMX6ULL_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-imx7 = "Colibri-iMX7_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-pxa = "Colibri-PXA_${IMAGE_BASENAME}"
IMAGE_NAME_colibri-vf = "Colibri-VF_${IMAGE_BASENAME}"
diff --git a/recipes-images/images/tdx-extra.inc b/recipes-images/images/tdx-extra.inc
index 9619aae..1d9e3bb 100644
--- a/recipes-images/images/tdx-extra.inc
+++ b/recipes-images/images/tdx-extra.inc
@@ -91,7 +91,7 @@ IMAGE_INSTALL_append_colibri-t20 = " \
#note that the kernel-modules meta package gets installed from
#meta-fsl-arm/conf/machine/include/imx-base.inc
-IMAGE_INSTALL_append_mx6 = " \
+IMAGE_INSTALL-MX6QDL = " \
bmode-usb \
libusbgx \
linuxptp \
@@ -109,6 +109,8 @@ IMAGE_INSTALL_append_mx6 = " \
e2fsprogs-tune2fs \
mimetypes \
"
+IMAGE_INSTALL_append_mx6q = "${IMAGE_INSTALL-MX6QDL}"
+IMAGE_INSTALL_append_mx6dl = "${IMAGE_INSTALL-MX6QDL}"
IMAGE_INSTALL_append_apalis-imx6 = " \
u-boot-toradex-fsl-fw-utils \
@@ -117,6 +119,16 @@ IMAGE_INSTALL_append_colibri-imx6 = " \
u-boot-toradex-fsl-fw-utils \
"
+IMAGE_INSTALL_append_mx6ull = " \
+ bmode-usb \
+ libusbgx \
+ linuxptp \
+ ptpd \
+ iproute2 \
+ canutils \
+ mtd-utils-ubifs \
+"
+
#note that the kernel-modules meta package gets installed from
#meta-fsl-arm/conf/machine/include/imx-base.inc
IMAGE_INSTALL_append_apalis-imx6 = " \
diff --git a/recipes-images/images/tdx-image-fstype.inc b/recipes-images/images/tdx-image-fstype.inc
index 83754b9..a2c6814 100644
--- a/recipes-images/images/tdx-image-fstype.inc
+++ b/recipes-images/images/tdx-image-fstype.inc
@@ -23,6 +23,7 @@ UBOOT_BINARY_tegra124m = "u-boot-dtb-tegra.${UBOOT_EXT}"
#we need some native tools for deployment
DEPENDS_append_mx6 = " imx-loader-native"
+DEPENDS_append_mx6ull = " mtd-utils-native imx-loader-native"
DEPENDS_append_mx7 = " mtd-utils-native imx-loader-native"
DEPENDS_append_tegra = " cbootimage-native tegrarcm-native"
DEPENDS_append_tegra124 = " cbootimage-native tegrarcm-native"
@@ -50,6 +51,24 @@ imagedeploytools_append_mx6() {
cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/mx6_usb_work.conf ${IMAGE_ROOT}/
}
+imagedeploytools_append_mx6ull() {
+ IMAGE_ROOT="${IMAGE_ROOTFS}/../imx_flash/"
+ rm -f ${IMAGE_ROOT}/mkfs.ubifs ${IMAGE_ROOT}/imx_usb
+ mkdir -p ${IMAGE_ROOT}
+
+ # add the mkfs.ubifs binary
+ cp ${STAGING_DIR_NATIVE}/usr/sbin/mkfs.ubifs ${IMAGE_ROOT}/
+ ${BUILD_STRIP} ${IMAGE_ROOT}/mkfs.ubifs
+
+ # add imx-loader and its configuration files
+ cp ${STAGING_BINDIR_NATIVE}/imx_usb ${IMAGE_ROOT}/
+ ${BUILD_STRIP} ${IMAGE_ROOT}/imx_usb
+
+# FIXME
+ cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/imx_usb.conf ${IMAGE_ROOT}/
+ cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/mx7_usb_work.conf ${IMAGE_ROOT}/
+}
+
imagedeploytools_append_mx7() {
IMAGE_ROOT="${IMAGE_ROOTFS}/../imx_flash/"
rm -f ${IMAGE_ROOT}/mkfs.ubifs ${IMAGE_ROOT}/imx_usb
@@ -64,6 +83,7 @@ imagedeploytools_append_mx7() {
${BUILD_STRIP} ${IMAGE_ROOT}/imx_usb
cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/imx_usb.conf ${IMAGE_ROOT}/
cp ${STAGING_ETCDIR_NATIVE}/imx-loader.d/mx7_usb_work.conf ${IMAGE_ROOT}/
+ cp ${IMAGE_ROOTFS}/../${MACHINE}_bin/${UBOOT_BINARY} ${IMAGE_ROOTFS}/../${MACHINE}_bin/u-boot.imx
}
imagedeploytools_append_tegra() {