summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-colibri-t20_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-colibri-t20_git.bb')
-rw-r--r--recipes-kernel/linux/linux-colibri-t20_git.bb17
1 files changed, 5 insertions, 12 deletions
diff --git a/recipes-kernel/linux/linux-colibri-t20_git.bb b/recipes-kernel/linux/linux-colibri-t20_git.bb
index 66c5f94..8612025 100644
--- a/recipes-kernel/linux/linux-colibri-t20_git.bb
+++ b/recipes-kernel/linux/linux-colibri-t20_git.bb
@@ -3,14 +3,11 @@ require recipes-kernel/linux/linux.inc
LINUX_VERSION ?= "3.1.10"
-SRCREV = "01451bf9a6ac778b401173b341adb1e32688e73f"
+SRCREV_colibri-t20 = "8ff26794f73da3caf815f348a03509f533b32ec2"
+PR_colibri-t20 = "V2.0b1"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
-PR = "V2.0a2"
S = "${WORKDIR}/git"
-#SRC_URI = "\
-# git://gitorious.org/colibri-t20-embedded-linux-bsp/colibri_t20-linux-kernel.git;protocol=git;branch=master \
-# file://bcm4329_warning.patch "
SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=colibri"
COMPATIBLE_MACHINE = "colibri-t20"
@@ -18,11 +15,7 @@ COMPATIBLE_MACHINE = "colibri-t20"
CMDLINE="mem=148M@0M fbmem=12M@148M nvmem=96M@160M vmalloc=248M video=tegrafb root=/dev/nfs ip=:::::eth0:on rw netdevwait mtdparts=tegra_nand:1018368K@28160K(userspace) console=ttyS0,115200n8 usb_high_speed=0"
do_configure_prepend_colibri-t20() {
- #use the defconfig provided in the kernel source tree
- install -m 0644 ${S}/arch/arm/configs/colibri_t20_defconfig ${WORKDIR}/defconfig
-
- #compile with -mno-unaligned-access, with 4.7 compiler the kernel fails
- echo "KBUILD_CFLAGS += -mno-unaligned-access" >> ${S}/Makefile
+ #use the defconfig provided in the kernel source tree
+ DEFCONFIG=`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`
+ oe_runmake $DEFCONFIG
}
-
-