summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxde-common/lxde-common_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-lxde/lxde-common/lxde-common_%.bbappend')
-rw-r--r--recipes-lxde/lxde-common/lxde-common_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-lxde/lxde-common/lxde-common_%.bbappend b/recipes-lxde/lxde-common/lxde-common_%.bbappend
index b0eb1c3..3ee2c8c 100644
--- a/recipes-lxde/lxde-common/lxde-common_%.bbappend
+++ b/recipes-lxde/lxde-common/lxde-common_%.bbappend
@@ -17,6 +17,7 @@ SRC_URI += " \
file://defaults.list \
file://0001-panel.in-add-to-panel-configuration.patch \
"
+SRC_URI_append_apalis-tk1 = "file://0002-panel.in-change-displayed-on-hdmi-monitor-configurat.patch"
# for apalis-imx6/colibri-imx6, we decide on the target during postinst
SRC_URI-MX6QDL = " \
@@ -49,6 +50,11 @@ do_install_append () {
install -m 0644 ${WORKDIR}/defaults.list ${D}/${datadir}/applications/
}
+do_install_append_apalis-tk1 () {
+ install -m 0644 ${D}/etc/xdg/lxpanel/LXDE/panels/panel ${D}/etc/xdg/lxpanel/LXDE/panels/panel2
+ sed -i 's/monitor=1/monitor=0/' ${D}/etc/xdg/lxpanel/LXDE/panels/panel2
+}
+
pkg_postinst_${PN}_vf () {
# can't do this offline
if [ "x$D" != "x" ]; then