summaryrefslogtreecommitdiff
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/packagegroup-qt5.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qt/qt5/packagegroup-qt5.bb b/recipes-qt/qt5/packagegroup-qt5.bb
new file mode 100644
index 0000000..c10115c
--- /dev/null
+++ b/recipes-qt/qt5/packagegroup-qt5.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "QT5 base package group"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit packagegroup
+
+RDEPENDS_${PN} = " \
+ qtbase \
+ qtbase-tools \
+ qtmultimedia \
+ qtsvg \
+ qtsensors \
+ qtsystems \
+ qtsystems-tools \
+ qtscript \
+ qtgraphicaleffects-qmlplugins \
+ qtconnectivity-qmlplugins \
+ qtlocation-plugins \
+ qtlocation-qmlplugins \
+ qtdeclarative \
+ ${QTWEBKIT} \
+"
+
+QTWEBKIT ??= "\
+ qtquick1 \
+ qtwebkit \
+"