summaryrefslogtreecommitdiff
path: root/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt4/qt4-x11-free-systemd.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt4/qt4-x11-free-systemd.bb b/recipes-qt/qt4/qt4-x11-free-systemd.bb
index 2c8227c..3e426f9 100644
--- a/recipes-qt/qt4/qt4-x11-free-systemd.bb
+++ b/recipes-qt/qt4/qt4-x11-free-systemd.bb
@@ -17,6 +17,9 @@ FILES_${PN} += " ${sysconfdir}/init.d "
do_install () {
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/qtdemo-init ${D}/${sysconfdir}/init.d/
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/qtdemo.service ${D}${systemd_unitdir}/system
}
NATIVE_SYSTEMD_SUPPORT = "1"