summaryrefslogtreecommitdiff
path: root/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch')
-rw-r--r--recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch b/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
new file mode 100644
index 0000000..4e6b921
--- /dev/null
+++ b/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
@@ -0,0 +1,19 @@
+diff --git a/Makefile b/Makefile
+index 7a1fc14..a0f8f4a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,12 +1,12 @@
+ INSTALL_PATH=$(DESTDIR)/usr/bin
+
+-LDFLAGS+=-lmcc
++LDLIBS+=-lmcc
+
+ all: build/mcc-pingpong
+
+ build/mcc-pingpong: src/pingpong.c
+ mkdir -p build/
+- $(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
++ $(CC) $< -o $@ $(CFLAGS) $(LDLIBS) $(LDFLAGS)
+
+ install:
+ mkdir -p $(INSTALL_PATH)