summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/glmark2/files/gl-char.patch11
-rw-r--r--recipes/glmark2/glmark2_2012.08.bb35
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes/glmark2/files/gl-char.patch b/recipes/glmark2/files/gl-char.patch
new file mode 100644
index 0000000..956191e
--- /dev/null
+++ b/recipes/glmark2/files/gl-char.patch
@@ -0,0 +1,11 @@
+--- glmark2-2012.08/src/gl-headers.h.orig 2012-11-14 11:11:43.991688984 +0100
++++ glmark2-2012.08/src/gl-headers.h 2012-11-14 11:13:45.581817248 +0100
+@@ -33,6 +33,8 @@
+ #elif USE_GLESv2
+ #include <GLES2/gl2.h>
+ #include <GLES2/gl2ext.h>
++/* provide GLchar which is not defined in our old gl2.h */
++typedef char GLchar;
+ #ifndef GL_WRITE_ONLY
+ #define GL_WRITE_ONLY GL_WRITE_ONLY_OES
+ #endif
diff --git a/recipes/glmark2/glmark2_2012.08.bb b/recipes/glmark2/glmark2_2012.08.bb
new file mode 100644
index 0000000..b85ebd4
--- /dev/null
+++ b/recipes/glmark2/glmark2_2012.08.bb
@@ -0,0 +1,35 @@
+SECTION = "debug"
+DESCRIPTION = "glmark2 is a benchmark for OpenGL (ES) 2.0. It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0."
+HOMEPAGE = "https://launchpad.net/glmark2"
+LICENSE ="GPLv3"
+RDEPENDS_${PN} = ""
+DEPENDS_${PN} = "python-native"
+
+SRC_URI = "https://launchpad.net/${PN}/trunk/${PV}/+download/${PN}-${PV}.tar.gz \
+ file://gl-char.patch"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+PR = "r4"
+
+do_configure() {
+}
+
+do_compile() {
+ ./waf configure --enable-glesv2 --prefix=/usr
+ ./waf
+ mkdir -p tmp/
+ cp build/src/glmark2* tmp/
+ ./waf configure --enable-glesv2 --prefix=${D}/usr
+ ./waf
+ rm build/src/glmark2*
+ cp tmp/glmark2* build/src/
+}
+
+FILES_${PN} += "/usr"
+do_install() {
+ ./waf install
+}
+
+SRC_URI[md5sum] = "f924a8019df2494222b718c47f6cbdc3"
+#SRC_URI[sha256sum] = "252390e4bc687957f09f334095904c8cc53b39c7b663ed47861ae1d11aef5946"