summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-01-28 12:21:56 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-01-30 19:31:32 +0100
commit50214be77d2c6d6ebe382f8aae57744d3eec9a6d (patch)
treea7a7ae9e2cb2c25a22a5de8a574667b3634783ba
parent4ac620794004e571ecca1a9d049563f28fa714cc (diff)
imx-vpu-hantro: upgrade to 1.20.0
Update package to version 1.20.0, which is aligned with NXP release imx_5.4.70_2.3.0. This package uses EULA v17 October 2020. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Taken from meta-freescale Related-to: ELB-3327 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--backports/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch54
-rw-r--r--backports/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb35
2 files changed, 89 insertions, 0 deletions
diff --git a/backports/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch b/backports/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch
new file mode 100644
index 0000000..8d9610d
--- /dev/null
+++ b/backports/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch
@@ -0,0 +1,54 @@
+From 5bfb24738c47003fd04a86bfd5a49f8c6354ed23 Mon Sep 17 00:00:00 2001
+From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
+Date: Fri, 28 Aug 2020 07:46:35 +0000
+Subject: [PATCH] decoder_sw: resolve compilation error with -fcommon
+
+-fcommon is enabled by default in gcc10 compiler, which results in
+following build errors:
+
+decoder_sw/software/source/inc/decapicommon.h:272: multiple definition
+of `DecPicCodingType'; decoder_sw/software/linux/dwl/dwl_linux.o:
+decoder_sw/software/source/inc/decapicommon.h:272: first defined here
+
+decoder_sw/software/source/inc/dwl.h:94: multiple definition of
+`DWLInitParam'; decoder_sw/software/linux/dwl/dwl_linux.o:
+decoder_sw/software/source/inc/dwl.h:94: first defined here
+
+Drop multiple enum name definitions, which solves above compilation
+issues.
+
+Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
+---
+ decoder_sw/software/source/inc/decapicommon.h | 2 +-
+ decoder_sw/software/source/inc/dwl.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/decoder_sw/software/source/inc/decapicommon.h b/decoder_sw/software/source/inc/decapicommon.h
+index 0f02092..fc8cccf 100755
+--- a/decoder_sw/software/source/inc/decapicommon.h
++++ b/decoder_sw/software/source/inc/decapicommon.h
+@@ -269,7 +269,7 @@ enum DecPicCodingType {
+ DEC_PIC_TYPE_D = 3,
+ DEC_PIC_TYPE_FI = 4,
+ DEC_PIC_TYPE_BI = 5
+-} DecPicCodingType;
++};
+
+ /* Output picture pixel format types for raster scan or down scale output */
+ enum DecPicturePixelFormat {
+diff --git a/decoder_sw/software/source/inc/dwl.h b/decoder_sw/software/source/inc/dwl.h
+index 6991f03..fd357b3 100755
+--- a/decoder_sw/software/source/inc/dwl.h
++++ b/decoder_sw/software/source/inc/dwl.h
+@@ -91,7 +91,7 @@ struct DWLLinearMem {
+ /* DWLInitParam is used to pass parameters when initializing the DWL */
+ struct DWLInitParam {
+ u32 client_type;
+-} DWLInitParam;
++};
+
+ /* Hardware configuration description, same as in top API */
+ typedef struct DecHwConfig DWLHwConfig;
+--
+2.17.1
+
diff --git a/backports/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb b/backports/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb
new file mode 100644
index 0000000..b7c64cb
--- /dev/null
+++ b/backports/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb
@@ -0,0 +1,35 @@
+# Copyright (C) 2017-2020 NXP
+
+DESCRIPTION = "i.MX Hantro VPU library"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cf3f9b8d09bc3926b1004ea71f7a248a"
+
+PROVIDES = "virtual/imxvpu"
+
+SRC_URI = " \
+ ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
+"
+SRC_URI[md5sum] = "682b3a73bf5aa22a37d56a433d11fc91"
+SRC_URI[sha256sum] = "e6cdd5b4c628604906466fc9620e2b048cf1b2c863f9ee49616dd5212b9261b0"
+
+inherit fsl-eula-unpack use-imx-headers
+
+PARALLEL_MAKE="-j 1"
+
+PLATFORM_mx8mm = "IMX8MM"
+PLATFORM_mx8mq = "IMX8MQ"
+PLATFORM_mx8mp = "IMX8MP"
+
+do_compile () {
+ oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \
+ SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
+ PLATFORM="${PLATFORM}" all
+}
+
+do_install () {
+ oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
+}
+
+FILES_${PN} += "/unit_tests"
+
+COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"