summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-01-28 10:41:04 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-01-30 19:31:32 +0100
commitcceaa0fc67f51aa4a4abea556b0347ec47c3d64f (patch)
tree25072519b9629c0398ffbd50b8afc45e3c3cd71d
parent5eed1ed77e0dd047034ef12fb7d5ad90f746629b (diff)
layer.conf: add backports directory and eula hashes
For recipes which are clean copies of a later release of an another layer put them in the backports directory. This allows for easier cleanup when upgrading to a later OE release. Additionally add the needed NXP EULA hashes for those backported recipes also here. Related-to: ELB-3327 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--conf/layer.conf13
1 files changed, 13 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 9eee66b..a9b910f 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -3,6 +3,8 @@ BBPATH .= ":${LAYERDIR}"
# We have recipes-* directories, add to BBFILES
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+# Recipes which backport later versions of other layers are placed here
+BBFILES += "${LAYERDIR}/backports/recipes-*/*/*.bb ${LAYERDIR}/backports/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "toradex-nxp-layer"
BBFILE_PATTERN_toradex-nxp-layer = "^${LAYERDIR}/"
@@ -23,3 +25,14 @@ LAYERDEPENDS_toradex-nxp-layer = " \
toradex-bsp-common-layer \
"
LAYERSERIES_COMPAT_toradex-nxp-layer = "zeus dunfell"
+
+FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V13 = "1b4db4b25c3a1e422c0c0ed64feb65d2"
+FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V15 = "983e4c77621568488dd902b27e0c2143"
+FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V16 = "e9e880185bda059c90c541d40ceca922"
+FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V17 = "cf3f9b8d09bc3926b1004ea71f7a248a"
+FSL_EULA_FILE_MD5SUMS_append = " \
+ ${FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V13} \
+ ${FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V15} \
+ ${FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V16} \
+ ${FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V17} \
+"