summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-05-03 22:21:39 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-05-06 10:44:14 +0200
commitdc80e813d1e9dd11102d5a27a0cf27df8153d64d (patch)
treeb2d1dfa465848af7d16ef9b1e4e829c4718de6e8
parent28e53cfa17bf8f34a7a35cc2dfee2095e4560052 (diff)
imx-seco: update to 3.7.5
Related-to: ELB-3957 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--backports/recipes-bsp/imx-seco/imx-seco-libs/0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch34
-rw-r--r--backports/recipes-bsp/imx-seco/imx-seco-libs_git.bb7
-rw-r--r--backports/recipes-bsp/imx-seco/imx-seco_3.7.5.bb (renamed from backports/recipes-bsp/imx-seco/imx-seco_3.7.4.bb)8
3 files changed, 40 insertions, 9 deletions
diff --git a/backports/recipes-bsp/imx-seco/imx-seco-libs/0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch b/backports/recipes-bsp/imx-seco/imx-seco-libs/0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch
new file mode 100644
index 0000000..757b9a6
--- /dev/null
+++ b/backports/recipes-bsp/imx-seco/imx-seco-libs/0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch
@@ -0,0 +1,34 @@
+From 59608dcb0f0a6f6d8154b1d331c2403d7c1143eb Mon Sep 17 00:00:00 2001
+From: Cristinel Panfir <cristinel.panfir@nxp.com>
+Date: Fri, 5 Feb 2021 19:27:00 +0200
+Subject: [PATCH] Makefile: Fix install to clear host-user-contaminated
+ warnings [HSM-483]
+
+WARNING: imx-seco-libs-git-r0 do_package_qa: QA Issue:
+imx-seco-libs: /usr/lib/hsm_lib.a is owned by uid 26292, which is the same as the user running bitbake. This may be due to host contamination
+imx-seco-libs: /usr/lib/she_lib.a is owned by uid 26292, which is the same as the user running bitbake. This may be due to host contamination
+imx-seco-libs: /usr/lib/seco_nvm_manager.a is owned by uid 26292, which is the same as the user running bitbake.
+This may be due to host contamination [host-user-contaminated]
+
+Upstream-Status: Pending
+
+Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 492d700..25ad333 100644
+--- a/Makefile
++++ b/Makefile
+@@ -63,7 +63,7 @@ hsm_doc: include/hsm/hsm_api.h
+
+ install: hsm_test she_test she_lib.a seco_nvm_manager.a hsm_lib.a
+ mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(LIBDIR) $(DESTDIR)$(INCLUDEDIR)
+- cp -a seco_nvm_manager.a hsm_lib.a she_lib.a $(DESTDIR)$(LIBDIR)
++ cp seco_nvm_manager.a hsm_lib.a she_lib.a $(DESTDIR)$(LIBDIR)
+ cp hsm_test she_test $(DESTDIR)$(BINDIR)
+ cp -a include/* $(DESTDIR)$(INCLUDEDIR)
+
+--
+2.25.1
diff --git a/backports/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/backports/recipes-bsp/imx-seco/imx-seco-libs_git.bb
index 220b4cc..dc37cdf 100644
--- a/backports/recipes-bsp/imx-seco/imx-seco-libs_git.bb
+++ b/backports/recipes-bsp/imx-seco/imx-seco-libs_git.bb
@@ -8,9 +8,10 @@ LIC_FILES_CHKSUM = "file://EULA.txt;md5=228c72f2a91452b8a03c4cab30f30ef9"
DEPENDS = "zlib"
-SRCBRANCH = "imx_5.4.70_2.3.0"
-SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "b730ba5975644094f224faee20942f63d0d24ccd"
+SRCBRANCH = "imx_5.4.70_2.3.1"
+SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \
+ file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch"
+SRCREV = "79e5fb5d096c61b1c3163c9fa8e42719509d95a0"
S = "${WORKDIR}/git"
diff --git a/backports/recipes-bsp/imx-seco/imx-seco_3.7.4.bb b/backports/recipes-bsp/imx-seco/imx-seco_3.7.5.bb
index 142d115..6af35de 100644
--- a/backports/recipes-bsp/imx-seco/imx-seco_3.7.4.bb
+++ b/backports/recipes-bsp/imx-seco/imx-seco_3.7.5.bb
@@ -5,17 +5,13 @@ DESCRIPTION = "NXP IMX SECO firmware"
SECTION = "base"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://COPYING;md5=cf3f9b8d09bc3926b1004ea71f7a248a"
-FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V17 = "cf3f9b8d09bc3926b1004ea71f7a248a"
-FSL_EULA_FILE_MD5SUMS_append = " \
- ${FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V17} \
-"
inherit fsl-eula-unpack use-imx-security-controller-firmware deploy
SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
-SRC_URI[md5sum] = "f0e20216f27f2f44ac809634c5291be5"
-SRC_URI[sha256sum] = "2ed8177e48c8e33f742b3a642805be56a5ef56df78b1b29e10518552154da2bc"
+SRC_URI[md5sum] = "d4faca131abfc51a1dd0278d7d201159"
+SRC_URI[sha256sum] = "08cf25a4be6841ca7264a50b29c311b386eae1c02fced8a3b55fd04213acb4bc"
do_compile[noexec] = "1"