summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-04-20 12:55:29 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2015-05-12 10:06:07 +0200
commit8c6ffc16cfa73733786d38dd9c8bbc20ae8a9a5e (patch)
tree235e74868fb0110c61fa8730f252f3744bede4c4
parent3d51a914c634d73cd831ccd73463e10e9b2746ab (diff)
Apalis/Colibri iMX6: kernel/U-Boot update to latest in -next
Also deploy an additional device tree supporting a Colibri iMX6 with Analog Camera Module.
-rw-r--r--conf/machine/apalis-imx6.conf2
-rw-r--r--conf/machine/colibri-imx6.conf4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb20
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb11
-rw-r--r--recipes-kernel/linux/linux-toradex-fsl_git.bb4
5 files changed, 16 insertions, 25 deletions
diff --git a/conf/machine/apalis-imx6.conf b/conf/machine/apalis-imx6.conf
index 23d6528..c0f5fa5 100644
--- a/conf/machine/apalis-imx6.conf
+++ b/conf/machine/apalis-imx6.conf
@@ -20,7 +20,7 @@ PREFERRED_VERSION_xserver-xorg_mx6 = "99:1.14%"
# don't pull in systemd 216 backported into meta-angstrom
PREFERRED_VERSION_systemd = "211%"
-UBOOT_MACHINE = "apalis_imx6q1g_config"
+UBOOT_MACHINE = "apalis_imx6_defconfig"
SERIAL_CONSOLE = "115200 ttymxc0"
diff --git a/conf/machine/colibri-imx6.conf b/conf/machine/colibri-imx6.conf
index 25c1f36..b9ea652 100644
--- a/conf/machine/colibri-imx6.conf
+++ b/conf/machine/colibri-imx6.conf
@@ -12,7 +12,7 @@ SOC_FAMILY = "mx6:mx6dl"
PREFERRED_PROVIDER_u-boot = "u-boot-toradex-fsl"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-fsl"
PREFERRED_PROVIDER_virtual/kernel = "linux-toradex-fsl"
-KERNEL_DEVICETREE = "imx6dl-colibri-eval-v3.dtb"
+KERNEL_DEVICETREE = "imx6dl-colibri-eval-v3.dtb imx6dl-colibri-cam-eval-v3.dtb"
KERNEL_IMAGETYPE = "uImage"
PREFERRED_VERSION_xserver-xorg_mx6 = "99:1.14%"
@@ -20,7 +20,7 @@ PREFERRED_VERSION_xserver-xorg_mx6 = "99:1.14%"
# don't pull in systemd 216 backported into meta-angstrom
PREFERRED_VERSION_systemd = "211%"
-UBOOT_MACHINE = "colibri_imx6s256m_config"
+UBOOT_MACHINE = "colibri_imx6_defconfig"
SERIAL_CONSOLE = "115200 ttymxc0"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
index be99752..4f671e0 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -1,7 +1,6 @@
SUMMARY = "U-boot bootloader fw_printenv/setenv utils"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM_colibri-vf = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
SECTION = "bootloader"
PROVIDES = "u-boot-fw-utils"
DEPENDS = "mtd-utils"
@@ -13,10 +12,10 @@ DEFAULT_PREFERENCE_colibri-imx6 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRCREV_colibri-vf = "73b99ed96be527c482e63f8d0aac4e6188b1f7e0"
-SRCREV_mx6 = "0260e62f008aa292d87da7c1a9fbe1051a793518"
-SRCBRANCH_colibri-vf = "2014.10-toradex"
-SRCBRANCH_mx6 = "2014.04-toradex"
+SRCREV_colibri-vf = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCREV_mx6 = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCBRANCH_colibri-vf = "2015.04-toradex-next"
+SRCBRANCH_mx6 = "2015.04-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
file://fw_env.config \
"
@@ -35,16 +34,9 @@ do_compile () {
oe_runmake env
}
-do_install_colibri-vf () {
- install -d ${D}${base_sbindir} ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- ln -s fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
-}
-
do_install () {
install -d ${D}${base_sbindir} ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv_unstripped ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
ln -s fw_printenv ${D}${base_sbindir}/fw_setenv
install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
}
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
index 9389a25..78bc4ff 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
@@ -3,18 +3,17 @@ require recipes-bsp/u-boot/u-boot.inc
PROVIDES += "u-boot"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
-LIC_FILES_CHKSUM_colibri-vf = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
PV = "${PR}+gitr${SRCREV}"
PR = "r0"
S = "${WORKDIR}/git"
-SRCREV_colibri-vf = "93d011ae1319c297d3cf31d40a88b21699d89d7b"
+SRCREV_colibri-vf = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
SRCBRANCH_colibri-vf = "2015.04-toradex-next"
-SRCREV_mx6 = "0260e62f008aa292d87da7c1a9fbe1051a793518"
-SRCBRANCH_mx6 = "2014.04-toradex"
+SRCREV_mx6 = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCBRANCH_mx6 = "2015.04-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
#FILESPATHPKG =. "git:"
@@ -46,7 +45,7 @@ SPL_SYMLINK_apalis-imx6 = "u-boot-it-${MACHINE}.imx"
do_compile_append_apalis-imx6() {
# keep u-boot with standard timings
mv u-boot.imx u-boot-std.imx
- oe_runmake apalis_imx6q2g_config
+ oe_runmake apalis_imx6_defconfig
oe_runmake ${UBOOT_MAKE_TARGET}
mv u-boot.imx u-boot-it.imx
mv u-boot-std.imx u-boot.imx
diff --git a/recipes-kernel/linux/linux-toradex-fsl_git.bb b/recipes-kernel/linux/linux-toradex-fsl_git.bb
index 2932684..c7a9c1a 100644
--- a/recipes-kernel/linux/linux-toradex-fsl_git.bb
+++ b/recipes-kernel/linux/linux-toradex-fsl_git.bb
@@ -11,8 +11,8 @@ DEPENDS += "lzop-native "
LINUX_VERSION_mx6 = "3.10.17"
-SRCREV_mx6 = "23b22e549ed6ede5b44a948824463daafb6745c3"
-PR_mx6 = "V2.3b5"
+SRCREV_mx6 = "2927fd34b6cfc68e3db459cceebdaa9f6fea664d"
+PR_mx6 = "V2.4b1"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"