summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-05-25 15:59:30 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-05-26 09:25:46 +0200
commit3be41c0a042994079bdf1577d6062ac0df46fc0a (patch)
tree8bec63f1f8479258b1b8d333d8a13c4954263ab3
parent5c9341abde257b9c1f6d3c8b4812437188990d2d (diff)
imx-atf: react with reset to a system reboot
I.e. reset the whole SoC rather than just the AP partition. Related-to: ELB-2702 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch41
-rw-r--r--recipes-bsp/imx-atf/imx-atf_%.bbappend5
2 files changed, 45 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch b/recipes-bsp/imx-atf/imx-atf/0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch
new file mode 100644
index 0000000..052aa3a
--- /dev/null
+++ b/recipes-bsp/imx-atf/imx-atf/0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch
@@ -0,0 +1,41 @@
+From a307f33f84b76871ac6879ce93d26525af3e5bd9 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Tue, 19 May 2020 20:32:59 +0200
+Subject: [PATCH] Revert "Add NXP's SoCs partition reboot support."
+
+This reverts commit 13a5c7ece5a13c636e52f22b45f592b72b6453d1.
+With commit 13a5c7ece5a1 the SCFW will execute a reboot of the AP
+partition as a reaction to a psci_system_reboot, e.g. because of
+a Linux reboot.
+
+This does only reset the SoC partly, i.e. only IP which will not affect
+other partitions. As a result on Apalis iMX8 USB HSIC comes up in a
+state were it does not recognize our USB3503 hub correctly.
+
+Refer to the SCFW doc file sc_fw_port.pdf for more info on the various
+sc_reboot*, sc_reset* functionalities.
+
+Upstream-Status: Inappropriate [configuration]
+
+Related-to: ELB-2702
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ plat/imx/common/imx8_psci.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plat/imx/common/imx8_psci.c b/plat/imx/common/imx8_psci.c
+index bf0b2f6b1..310f81c2e 100644
+--- a/plat/imx/common/imx8_psci.c
++++ b/plat/imx/common/imx8_psci.c
+@@ -21,7 +21,7 @@ void __dead2 imx_system_off(void)
+
+ void __dead2 imx_system_reset(void)
+ {
+- sc_pm_reboot(ipc_handle, SC_PM_RESET_TYPE_COLD);
++ sc_pm_reset(ipc_handle, SC_PM_RESET_TYPE_BOARD);
+ wfi();
+ ERROR("system reset failed.\n");
+ panic();
+--
+2.20.1
+
diff --git a/recipes-bsp/imx-atf/imx-atf_%.bbappend b/recipes-bsp/imx-atf/imx-atf_%.bbappend
index 5d0247e..08549a8 100644
--- a/recipes-bsp/imx-atf/imx-atf_%.bbappend
+++ b/recipes-bsp/imx-atf/imx-atf_%.bbappend
@@ -5,7 +5,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append = " file://0001-imx8m-imx_rdc.c-fix-a-uninitialized-variable.patch"
+SRC_URI_append = " \
+ file://0001-imx8m-imx_rdc.c-fix-a-uninitialized-variable.patch \
+ file://0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch \
+"
PV = "2.0+git${SRCPV}"
SRCBRANCH = "imx_4.14.98_2.3.0"