summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-06-18 10:30:21 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-18 12:09:04 +0200
commitaae172f7a1c11d45e7e52b7906f02c3366feaa53 (patch)
tree9d61b54c2e30d44a91a64debf13930f0d8329512
parentf7ebd294c81285a6579b10a09e49a3d635ac4b70 (diff)
bmode-usb: replace soc overrides to also include use-mainline-bsp
With use-mainline-bsp the SoC overrides mx6/mx6q/mx6ull... are filtered out of the overrides. Replace them with the specific machine name. Related-to: ELB-2805 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-support/bmode-usb/bmode-usb_1.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-support/bmode-usb/bmode-usb_1.0.bb b/recipes-support/bmode-usb/bmode-usb_1.0.bb
index a6c14e0..752c09b 100644
--- a/recipes-support/bmode-usb/bmode-usb_1.0.bb
+++ b/recipes-support/bmode-usb/bmode-usb_1.0.bb
@@ -5,8 +5,9 @@ LIC_FILES_CHKSUM = "file://bmode_usb.c;endline=5;md5=4c9010cb42fb7648a460c35e6b5
SRC_URI = "file://bmode_usb.c"
S = "${WORKDIR}"
DEFINE = "NO_MACHINE"
-DEFINE_mx6 = "MX6"
-DEFINE_mx6ull = "MX6ULL"
+DEFINE_apalis-imx6 = "MX6"
+DEFINE_colibri-imx6 = "MX6"
+DEFINE_colibri-imx6ull = "MX6ULL"
do_compile() {
${CC} -o bmode_usb bmode_usb.c ${CFLAGS} ${LDFLAGS} -D ${DEFINE}