summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-11-27 17:26:39 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-11-27 17:55:24 +0100
commit3a2c12757d6c6ccf57f8f3e5ca2d7080882cff7c (patch)
treefb5890b7a0d95898f7ee7858342fe3b4c8379c66
parent7140ef471f0575414297a1a2b6aadd0ff8ae263b (diff)
imx-boot: replace lnr with a call to ln
openembedded core removed the lnr script with commit 723b6e40f5 ("scripts/lnr: remove"). Replace the call to it with 'ln -frs'. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
index 8abacd9..02546ad 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
+++ b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
@@ -5,5 +5,5 @@ compile_mx8m:prepend() {
}
compile_mx8m:append() {
rm -rf ${BOOT_STAGING}/mkimage_uboot
- lnr ${STAGING_DIR_NATIVE}/${bindir}/mkimage ${BOOT_STAGING}/mkimage_uboot
+ ln -frs ${STAGING_DIR_NATIVE}/${bindir}/mkimage ${BOOT_STAGING}/mkimage_uboot
}