summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-11-04 16:24:51 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-02-22 18:34:26 +0100
commit58d8aaa8e47ff466f2cf70a6f2ab2b9f3f96f51a (patch)
tree75e01d28b9370a13cbf385bb60e30f8f5aa41770
parente77fea90da6e2fa44eb9c3597893d6c8a104417a (diff)
linux-toradex-mainline: disable configs that lead to latency
Explicitly disable kernel configs that could lead to latency on preempt-rt kernel. Also explicitly enable CONFIG_EXPERT, which is being depended by CONFIG_PREEMPT_RT. Related-to: TOR-1354 Signed-off-by: Ming Liu <ming.liu@toradex.com> (cherry picked from commit 7158ef9e45d854bb92aaf3074b25b80663d185b6)
-rw-r--r--recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt-less-latency.cfg14
-rw-r--r--recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt-less-latency.scc4
-rw-r--r--recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg1
-rw-r--r--recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb1
4 files changed, 20 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt-less-latency.cfg b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt-less-latency.cfg
new file mode 100644
index 0000000..a9c88bd
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt-less-latency.cfg
@@ -0,0 +1,14 @@
+# CONFIG_PM_DEBUG is not set
+# CONFIG_6LOWPAN_DEBUGFS is not set
+# CONFIG_BT_DEBUGFS is not set
+# CONFIG_ATH9K_DEBUGFS is not set
+# CONFIG_ATH9K_HTC_DEBUGFS is not set
+# CONFIG_ATH10K_DEBUGFS is not set
+# CONFIG_RTLWIFI_DEBUG is not set
+# CONFIG_IEEE802154_AT86RF230_DEBUGFS is not set
+# CONFIG_DYNAMIC_DEBUG is not set
+# CONFIG_DETECT_HUNG_TASK is not set
+# CONFIG_SCHEDSTATS is not set
+# CONFIG_SCHED_DEBUG is not set
+# CONFIG_BLK_DEV_IO_TRACE is not set
+# CONFIG_CORESIGHT is not set
diff --git a/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt-less-latency.scc b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt-less-latency.scc
new file mode 100644
index 0000000..edd1519
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt-less-latency.scc
@@ -0,0 +1,4 @@
+define KFEATURE_DESCRIPTION "Disable configs that could lead to preempt-rt latency"
+define KFEATURE_COMPATIBILITY board
+
+kconf non-hardware preempt-rt-less-latency.cfg
diff --git a/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg
index 93e05af..f76e447 100644
--- a/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg
+++ b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg
@@ -1,3 +1,4 @@
+CONFIG_EXPERT=y
# CONFIG_PREEMPT_NONE is not set
# CONFIG_PREEMPT_VOLUNTARY is not set
# CONFIG_PREEMPT is not set
diff --git a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
index b5edc7c..261af71 100644
--- a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
+++ b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
@@ -46,6 +46,7 @@ MIRRORS_append_preempt-rt = "${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/ol
SRC_URI_append_preempt-rt = " \
${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/older/patch-5.4.77-rt43.patch.xz;name=rt-patch \
file://preempt-rt.scc \
+ file://preempt-rt-less-latency.scc \
"
# This patches do currently not apply but are likely needed or we get
# runtime bugs.