summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-09-05 20:22:02 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-09-06 13:19:08 +0200
commitcbe8810ddff00711a64485e169e90530903e5cc0 (patch)
tree6350967e6ef66b985b350a9669e324e916fe3c52
parente606b785cc167f38318c2896eac0964a4c083246 (diff)
manual override syntax fixes
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--conf/machine/include/colibri-imx6ull-emmc.inc1
-rw-r--r--conf/machine/include/colibri-imx6ull.inc2
-rw-r--r--conf/machine/include/colibri-imx7-emmc.inc2
-rw-r--r--recipes-bsp/imx-atf/imx-atf_%.bbappend2
-rw-r--r--recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc2
-rw-r--r--recipes-kernel/linux/device-tree-overlays_git.bb2
-rw-r--r--recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb4
9 files changed, 10 insertions, 9 deletions
diff --git a/conf/machine/include/colibri-imx6ull-emmc.inc b/conf/machine/include/colibri-imx6ull-emmc.inc
index 5069fe6..ede4555 100644
--- a/conf/machine/include/colibri-imx6ull-emmc.inc
+++ b/conf/machine/include/colibri-imx6ull-emmc.inc
@@ -14,6 +14,7 @@ PREFERRED_PROVIDER_u-boot-default-script = "u-boot-distro-boot"
# MACHINEOVERRIDES:append:upstream = ":use-mainline-bsp"
UBOOT_MAKE_TARGET:colibri-imx6ull-emmc = "u-boot.imx"
+UBOOT_SUFFIX:${MACHINE} = "imx"
UBOOT_ENTRYPOINT:colibri-imx6ull-emmc = "0x81000000"
UBOOT_DTB_LOADADDRESS:colibri-imx6ull-emmc = "0x82100000"
UBOOT_DTBO_LOADADDRESS:colibri-imx6ull-emmc = "0x87000000"
diff --git a/conf/machine/include/colibri-imx6ull.inc b/conf/machine/include/colibri-imx6ull.inc
index 7f62303..c6538d2 100644
--- a/conf/machine/include/colibri-imx6ull.inc
+++ b/conf/machine/include/colibri-imx6ull.inc
@@ -22,7 +22,7 @@ UBOOT_ENTRYPOINT:colibri-imx6ull = "0x81000000"
UBOOT_DTB_LOADADDRESS:colibri-imx6ull = "0x82100000"
UBOOT_DTBO_LOADADDRESS:colibri-imx6ull = "0x87000000"
-KERNEL_DEVICETREE:append_use_nxp_bsp = " \
+KERNEL_DEVICETREE:append:use_nxp_bsp = " \
imx6ull-colibri-aster.dtb \
imx6ull-colibri-iris.dtb \
imx6ull-colibri-iris-v2.dtb \
diff --git a/conf/machine/include/colibri-imx7-emmc.inc b/conf/machine/include/colibri-imx7-emmc.inc
index db64648..a656bf9 100644
--- a/conf/machine/include/colibri-imx7-emmc.inc
+++ b/conf/machine/include/colibri-imx7-emmc.inc
@@ -36,4 +36,4 @@ UBOOT_DTB_LOADADDRESS:colibri-imx7-emmc = "0x82000000"
UBOOT_DTBO_LOADADDRESS:colibri-imx7-emmc = "0x87000000"
UBOOT_ENTRYPOINT:colibri-imx7-emmc = "0x81000000"
UBOOT_MAKE_TARGET = "u-boot.imx"
-UBOOT_SUFFIX_${MACHINE} = "imx"
+UBOOT_SUFFIX:${MACHINE} = "imx"
diff --git a/recipes-bsp/imx-atf/imx-atf_%.bbappend b/recipes-bsp/imx-atf/imx-atf_%.bbappend
index 7060815..f8fbddd 100644
--- a/recipes-bsp/imx-atf/imx-atf_%.bbappend
+++ b/recipes-bsp/imx-atf/imx-atf_%.bbappend
@@ -1,7 +1,7 @@
PV = "2.2+git${SRCPV}"
SRCBRANCH = "toradex_imx_5.4.70_2.3.0"
SRCREV = "835a8f67b2ca7aa3f2d05d6e6a1a51f7e1147266"
-SRCREV_use-head-next = "${AUTOREV}"
+SRCREV:use-head-next = "${AUTOREV}"
SRC_URI = "git://git.toradex.com/imx-atf.git;protocol=https;branch=${SRCBRANCH}"
EXTRA_OEMAKE:append = " \
diff --git a/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb b/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb
index 28221c9..dfc9b67 100644
--- a/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb
+++ b/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.7.0.bb
@@ -12,7 +12,7 @@ inherit deploy
SRC_URI = "git://github.com/toradex/i.MX-System-Controller-Firmware.git;branch=master;protocol=https;fsl-eula=true"
SRCREV = "64fd890f0be17c2c2939e66b5ddf3d60246f574b"
-SRCREV_use-head-next = "${AUTOREV}"
+SRCREV:use-head-next = "${AUTOREV}"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common.inc b/recipes-bsp/u-boot/u-boot-toradex-common.inc
index 812f779..8ed3611 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-common.inc
+++ b/recipes-bsp/u-boot/u-boot-toradex-common.inc
@@ -14,7 +14,7 @@ inherit toradex-u-boot-localversion
# repo during parse
SRCREV = "0401650db5dfaf5fe67cb2ed8e9285bb198f3245"
SRCBRANCH = "toradex_2020.07"
-SRCREV_use-head-next = "${AUTOREV}"
+SRCREV:use-head-next = "${AUTOREV}"
SRC_URI = " \
git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH} \
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc b/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
index 39d3c28..2978b2d 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
+++ b/recipes-bsp/u-boot/u-boot-toradex-common_2020.04.inc
@@ -11,7 +11,7 @@ SRC_URI = " \
"
SRCREV = "f499632b31f88dbd313fe9f742e2019c56032558"
-SRCREV_use-head-next = "${AUTOREV}"
+SRCREV:use-head-next = "${AUTOREV}"
SRCBRANCH = "toradex_imx_v2020.04_5.4.70_2.3.0"
S = "${WORKDIR}/git"
diff --git a/recipes-kernel/linux/device-tree-overlays_git.bb b/recipes-kernel/linux/device-tree-overlays_git.bb
index db103cb..f190ed0 100644
--- a/recipes-kernel/linux/device-tree-overlays_git.bb
+++ b/recipes-kernel/linux/device-tree-overlays_git.bb
@@ -2,7 +2,7 @@ inherit toradex-devicetree
SRCBRANCH = "toradex_5.4-2.3.x-imx"
SRCREV = "a52d315e89af02a63ed5d43d77626a91e3e82da5"
-SRCREV_use-head-next = "${AUTOREV}"
+SRCREV:use-head-next = "${AUTOREV}"
# we have dtbo's in arm and arm64 architecture, set the include paths
# to include both architectures.
diff --git a/recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb b/recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb
index 044b86e..64956f7 100644
--- a/recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb
+++ b/recipes-kernel/linux/linux-toradex_5.4-2.3.x.bb
@@ -16,14 +16,14 @@ KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget'
inherit toradex-kernel-localversion
LINUX_VERSION = "5.4.129"
# skip, as with use-head-next LINUX_VERSION might be set wrongly
-KERNEL_VERSION_SANITY_SKIP_use-head-next = "1"
+KERNEL_VERSION_SANITY_SKIP:use-head-next = "1"
# Make sure to override LOCALVERSION in linux-imx.inc
LOCALVERSION = "-${TDX_VERSION}"
SRCBRANCH = "toradex_5.4-2.3.x-imx"
SRCREV_machine = "9443377ef940e51025f3d5df5a9232a6f994e5ff"
-SRCREV_machine_use-head-next = "${AUTOREV}"
+SRCREV_machine:use-head-next = "${AUTOREV}"
DEPENDS += "lzop-native bc-native"
COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"