summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2017-09-04 14:44:42 -0700
committerMax Krummenacher <max.krummenacher@toradex.com>2017-10-03 17:07:18 +0200
commit707cb8b83d327256abdbbf144ef99d83337a59a2 (patch)
tree6dc62ee84993c38eefb606ea7339a6d544b4edc5 /recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
parent60197688509b5c27fd4e62d97b3c6d53fc670528 (diff)
u-boot-toradex-fsl-fw-utils: add colibri-imx7-emmc support
Add fw_env.config and make sure unlock eMMC gets installed. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
index 0861fa3..93a99e5 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -21,8 +21,8 @@ SRCBRANCH = "2016.11-toradex"
SRC_URI = " \
git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
file://fw_env.config \
+ file://fw_unlock_mmc.sh \
"
-SRC_URI_append_mx6 = " file://fw_unlock_mmc.sh "
PV = "2016.11"
PR = "${TDX_VER_INT}-gitr${@d.getVar("SRCREV", False)[0:7]}"
@@ -48,9 +48,17 @@ do_install () {
install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
}
-do_install_append_mx6() {
+install_unlock_emmc() {
install -d ${D}${sysconfdir}/profile.d/
install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
}
+do_install_append_mx6() {
+ install_unlock_emmc
+}
+
+do_install_append_colibri-imx7-emmc() {
+ install_unlock_emmc
+}
+
PACKAGE_ARCH = "${MACHINE_ARCH}"