summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_2019.07.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-07-09 22:22:01 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-07-10 19:47:15 +0200
commitddcdce6443b4926840265ad39139d8e485ab579e (patch)
treeb7235af4372b522dec00ca3a295b1ecb635f9ea4 /recipes-bsp/u-boot/u-boot-toradex_2019.07.bb
parente605d184fa537450ab496f9d304740696499fef7 (diff)
u-boot-toradex: update to 2019.07
Update to a 2019.07 based U-Boot. Use the openembedded master recipes for u-boot_2019.07 as a base. This makes the u-boot recipe in recipes-bsp/u-boot-mainline/ obsolete, delete it. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_2019.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2019.07.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2019.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2019.07.bb
new file mode 100644
index 0000000..6e08268
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex_2019.07.bb
@@ -0,0 +1,20 @@
+require u-boot-toradex-common.inc
+require recipes-bsp/u-boot/u-boot.inc
+require recipes-bsp/u-boot/u-boot-toradex-initial-env.inc
+
+DEPENDS += "bc-native dtc-native"
+
+# U-Boot is flashed 1k into a NAND block, create a binary which prepends
+# U-boot with 1k of zeros to ease flashing
+
+nand_padding () {
+ dd bs=1024 count=1 if=/dev/zero | cat - u-boot.imx > u-boot-nand.imx
+}
+
+do_compile_append_colibri-imx6ull () {
+ nand_padding
+}
+
+do_compile_append_colibri-imx7 () {
+ nand_padding
+}