summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-03-29 12:25:20 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-04-01 10:11:35 +0200
commit7a76715041d351ec62b549685077037dcc9d56ea (patch)
tree7da4a4af5702ab2771e647cb3bff1e2ca5165bf9 /recipes-bsp/u-boot
parent82fdbc5bdc09e6ccb8a0c0ac52c5c4427138b529 (diff)
u-boot: add Apalis iMX6 and Colibri VF recipe
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
new file mode 100644
index 0000000..da6d04f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
@@ -0,0 +1,35 @@
+require recipes-bsp/u-boot/u-boot.inc
+
+PROVIDES += "u-boot"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM_colibri-vf = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+
+PV = "${PR}+gitr${SRCREV}"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+SRCREV_colibri-vf = "f624e019a3f37ee4415a407afae0e026dd203714"
+SRCREV_apalis-imx6 = "26ddd931bf983503b07fe0f58c9c6476b1c9d6ae"
+SRCBRANCH_colibri-vf = "colibri_vf"
+SRCBRANCH_apalis-imx6 = "toradex_imx6"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
+
+#FILESPATHPKG =. "git:"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(colibri-vf|apalis-imx6)"
+DEFAULT_PREFERENCE_colibri-vf = "1"
+DEFAULT_PREFERENCE_apalis-imx6 = "1"
+
+# colibri_vf: build additionally a u-boot binary used for sd-card boot
+SPL_BINARY_colibri-vf = "u-boot.imx"
+SPL_IMAGE_colibri-vf = "u-boot-${MACHINE}-${PV}-${PR}.imx"
+SPL_SYMLINK_colibri-vf = "u-boot-${MACHINE}.imx"
+do_compile_append_colibri-vf() {
+ oe_runmake colibri_vf_sdboot_config
+ oe_runmake
+}