summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-04-29 18:40:09 +0200
committerStefan Agner <stefan.agner@toradex.com>2014-04-30 15:39:06 +0200
commitcd7860d5a3035cdd9e167ee99fcb3c8321e1ffa7 (patch)
tree75886792ebd76a229decd5aab81de9cb942f8596 /recipes-bsp
parent03e76333ecd15106d9327e7880ba84b9ad630177 (diff)
colibri-vf: switch to U-Boot 2014.04 and latest git
This commit switches Colibri VF machine to use the 2014.04 git branch. The change to latest U-Boot brings proper NAND hardware ECC support, which is also enabled in latest Linux kernel. Beside that, burnflash is updated to correctly work with the new U-Boot version and the altered Config Block location.
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb25
1 files changed, 14 insertions, 11 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
index 944a49c..aa238d4 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
@@ -3,8 +3,6 @@ require recipes-bsp/u-boot/u-boot.inc
PROVIDES += "u-boot"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM_colibri-vf = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
- file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
PV = "${PR}+gitr${SRCREV}"
@@ -12,9 +10,9 @@ PR = "r0"
S = "${WORKDIR}/git"
-SRCREV_colibri-vf = "f624e019a3f37ee4415a407afae0e026dd203714"
+SRCREV_colibri-vf = "2500368a9806f2fdfbf20d656fe265573d4d6b0b"
SRCREV_apalis-imx6 = "214db18e6c38454e1c4d22b472dda07db062f976"
-SRCBRANCH_colibri-vf = "colibri_vf"
+SRCBRANCH_colibri-vf = "2014.04-colibri_vf"
SRCBRANCH_apalis-imx6 = "toradex_imx6"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
@@ -25,11 +23,16 @@ COMPATIBLE_MACHINE = "(colibri-vf|apalis-imx6)"
DEFAULT_PREFERENCE_colibri-vf = "1"
DEFAULT_PREFERENCE_apalis-imx6 = "1"
-# colibri_vf: build additionally a u-boot binary used for sd-card boot
-SPL_BINARY_colibri-vf = "u-boot.imx"
-SPL_IMAGE_colibri-vf = "u-boot-${MACHINE}-${PV}-${PR}.imx"
-SPL_SYMLINK_colibri-vf = "u-boot-${MACHINE}.imx"
-do_compile_append_colibri-vf() {
- oe_runmake colibri_vf_sdboot_config
- oe_runmake
+# colibri_vf: copy additional U-Boot binary for NAND
+UBOOT_BINARY_NAND_colibri-vf = "u-boot-nand.imx"
+UBOOT_IMAGE_NAND_colibri-vf = "u-boot-nand-${MACHINE}-${PV}-${PR}.imx"
+UBOOT_SYMLINK_NAND_colibri-vf = "u-boot-nand-${MACHINE}.imx"
+
+do_deploy_append_colibri-vf() {
+ install ${S}/${UBOOT_BINARY_NAND} ${DEPLOYDIR}/${UBOOT_IMAGE_NAND}
+
+ cd ${DEPLOYDIR}
+ rm -f ${UBOOT_BINARY_NAND} ${UBOOT_SYMLINK_NAND}
+ ln -sf ${UBOOT_IMAGE_NAND} ${UBOOT_SYMLINK_NAND}
+ ln -sf ${UBOOT_IMAGE_NAND} ${UBOOT_BINARY_NAND}
}