summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
new file mode 100644
index 0000000..e4f88b1
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM_colibri-vf = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+SECTION = "bootloader"
+PROVIDES = "u-boot-fw-utils"
+DEPENDS = "mtd-utils"
+
+COMPATIBLE_MACHINE = "(colibri-vf|apalis-imx6)"
+DEFAULT_PREFERENCE_colibri-vf = "1"
+DEFAULT_PREFERENCE_apalis-imx6 = "1"
+
+FILESPATHPKG =. "git:"
+S="${WORKDIR}/git"
+SRCREV_colibri-vf = "f624e019a3f37ee4415a407afae0e026dd203714"
+SRCREV_apalis-imx6 = "214db18e6c38454e1c4d22b472dda07db062f976"
+SRCBRANCH_colibri-vf = "colibri_vf"
+SRCBRANCH_apalis-imx6 = "toradex_imx6"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
+
+PV = "${PR}+gitr${SRCREV}"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"