summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb20
1 files changed, 6 insertions, 14 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
index be99752..4f671e0 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -1,7 +1,6 @@
SUMMARY = "U-boot bootloader fw_printenv/setenv utils"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM_colibri-vf = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
SECTION = "bootloader"
PROVIDES = "u-boot-fw-utils"
DEPENDS = "mtd-utils"
@@ -13,10 +12,10 @@ DEFAULT_PREFERENCE_colibri-imx6 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRCREV_colibri-vf = "73b99ed96be527c482e63f8d0aac4e6188b1f7e0"
-SRCREV_mx6 = "0260e62f008aa292d87da7c1a9fbe1051a793518"
-SRCBRANCH_colibri-vf = "2014.10-toradex"
-SRCBRANCH_mx6 = "2014.04-toradex"
+SRCREV_colibri-vf = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCREV_mx6 = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCBRANCH_colibri-vf = "2015.04-toradex-next"
+SRCBRANCH_mx6 = "2015.04-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
file://fw_env.config \
"
@@ -35,16 +34,9 @@ do_compile () {
oe_runmake env
}
-do_install_colibri-vf () {
- install -d ${D}${base_sbindir} ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- ln -s fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
-}
-
do_install () {
install -d ${D}${base_sbindir} ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv_unstripped ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
ln -s fw_printenv ${D}${base_sbindir}/fw_setenv
install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
}