summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb19
1 files changed, 1 insertions, 18 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
index db7d276..af9430f 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
@@ -10,8 +10,6 @@ PR = "r0"
S = "${WORKDIR}/git"
-SRCREV_colibri-vf = "06ee8db6422e02337242e43b8573359443db59ea"
-SRCBRANCH_colibri-vf = "2015.04-toradex"
SRCREV_mx6 = "06ee8db6422e02337242e43b8573359443db59ea"
SRCBRANCH_mx6 = "2015.04-toradex"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
@@ -19,25 +17,10 @@ SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRA
#FILESPATHPKG =. "git:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(colibri-vf|colibri-imx6|apalis-imx6)"
-DEFAULT_PREFERENCE_colibri-vf = "1"
+COMPATIBLE_MACHINE = "(colibri-imx6|apalis-imx6)"
DEFAULT_PREFERENCE_apalis-imx6 = "1"
DEFAULT_PREFERENCE_colibri-imx6 = "1"
-# colibri_vf: copy additional U-Boot binary for NAND
-UBOOT_BINARY_NAND_colibri-vf = "u-boot-nand.imx"
-UBOOT_IMAGE_NAND_colibri-vf = "u-boot-nand-${MACHINE}-${PV}-${PR}.imx"
-UBOOT_SYMLINK_NAND_colibri-vf = "u-boot-nand-${MACHINE}.imx"
-
-do_deploy_append_colibri-vf() {
- install ${S}/${UBOOT_BINARY_NAND} ${DEPLOYDIR}/${UBOOT_IMAGE_NAND}
-
- cd ${DEPLOYDIR}
- rm -f ${UBOOT_BINARY_NAND} ${UBOOT_SYMLINK_NAND}
- ln -sf ${UBOOT_IMAGE_NAND} ${UBOOT_SYMLINK_NAND}
- ln -sf ${UBOOT_IMAGE_NAND} ${UBOOT_BINARY_NAND}
-}
-
# apalis-imx6: build additionally a u-boot binary for the IT variant
SPL_BINARY_apalis-imx6 = "u-boot-it.imx"
SPL_IMAGE_apalis-imx6 = "u-boot-it-${MACHINE}-${PV}-${PR}.imx"