summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBhuvanchandra DV <bhuvanchandra.dv@toradex.com>2016-09-08 16:40:50 +0530
committerMax Krummenacher <max.krummenacher@toradex.com>2016-09-29 20:59:56 +0200
commit38e36609e4057bb0c26fabbaa86aa96e38d24bda (patch)
tree332c3cc8164c06ae76989ea8a21431a000e433bc
parenta5ceb14a9389d0b2c3e371ae5514028719b45eb1 (diff)
apalis-tk1: lvds-tegra124: configure lvds in extended mode by default
Disabling LVDS output by default has issue with pcmanfm consuming 100% CPU if HDMI is inactive. So to make sure HDMI is set as primiary display and to address the issue with pcmanfm, configure LVDS in extended mode by default so that if HDMI is not active LVDS will be on atleast. Signed-off-by: Bhuvanchandra DV <bhuvanchandra.dv@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
index 0b778d6..99a2e59 100644
--- a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
+++ b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Disable LVDS output in favour of primary HDMI one on Apalis TK1"
+SUMMARY = "Configure LVDS output as extended mode in favour of primary HDMI one on Apalis TK1"
LICENSE = "PD"
SRC_URI = " \
@@ -11,7 +11,8 @@ ALLOW_EMPTY_${PN} = "1"
pkg_postinst_${PN}() {
mkdir -p ${sysconfdir}/xdg/lxsession/LXDE
- echo "${bindir}/xrandr --output LVDS-0 --off" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
+ echo "@xrandr --output HDMI-0 --auto --primary --output LVDS-0 --auto --right-of HDMI-0" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
+ echo "#@xrandr --output LVDS-0 --auto --primary --output HDMI-0 --auto --right-of LVDS-0" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
}
pkg_postrm_${PN}() {