summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-09-21 14:05:01 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2016-09-29 20:59:56 +0200
commit6cd5833d3afd0fb44ef62d7dbe080cb9e687883e (patch)
treec67797213eda0a67663c7c2025ae9a45cb09ba9a
parentb5b993d760f006dfb167b6fa588b67855bdd5aa2 (diff)
apalis-tk1: disable nvidia logo shown exlusively on lvds
Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--recipes-bsp/binary-drivers/linux-driver-package-21.5.0/xorg.conf22
-rw-r--r--recipes-bsp/binary-drivers/linux-driver-package_21.5.0.bbappend7
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/binary-drivers/linux-driver-package-21.5.0/xorg.conf b/recipes-bsp/binary-drivers/linux-driver-package-21.5.0/xorg.conf
new file mode 100644
index 0000000..68b7925
--- /dev/null
+++ b/recipes-bsp/binary-drivers/linux-driver-package-21.5.0/xorg.conf
@@ -0,0 +1,22 @@
+# Copyright (c) 2011-2013 NVIDIA CORPORATION. All Rights Reserved.
+
+#
+# This is the minimal configuration necessary to use the Tegra driver.
+# Please refer to the xorg.conf man page for more configuration
+# options provided by the X server, including display-related options
+# provided by RandR 1.2 and higher.
+
+# Disable extensions not useful on Tegra.
+Section "Module"
+ Disable "dri"
+ SubSection "extmod"
+ Option "omit xfree86-dga"
+ EndSubSection
+EndSection
+
+Section "Device"
+ Identifier "Tegra0"
+ Driver "nvidia"
+ Option "NoLogo" "true"
+EndSection
+
diff --git a/recipes-bsp/binary-drivers/linux-driver-package_21.5.0.bbappend b/recipes-bsp/binary-drivers/linux-driver-package_21.5.0.bbappend
new file mode 100644
index 0000000..55e6f37
--- /dev/null
+++ b/recipes-bsp/binary-drivers/linux-driver-package_21.5.0.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-driver-package-${PV}:"
+
+SRC_URI_append_apalis-tk1 = " file://xorg.conf"
+
+do_install_append_apalis-tk1 () {
+ cp ${WORKDIR}/xorg.conf ${D}/etc/X11/
+}